Version 9 (modified by toby, 5 years ago) (diff)


Python Packages Required in GSAS-II

GSAS-II requires that you have Python 2.7.x or Python 3.6 or later installed on your computer. Also, GSAS-II requires a a number of Python packages, as listed here.

We provide a single-file install distribution for (Windows, Mac OS X and Linux) that installs Python, the required packages and then downloads the latest version of GSAS-II.

Some users may prefer to install Python themselves. There are many distributions of Python available, but the easiest way to obtain Python with the required packages is to install the Anaconda (or Canopy) distributions, as described in the platform-specific installation instructions (Windows, Mac OS X or Linux). Linux users have the additional option of using pre-built Python dists from Redhat, Ubuntu, etc. This can sometimes be required as some older or very new dists can have compatibility problems with Anaconda, etc.

At present, GSAS-II is being developed with Python version 2.7 (up to 2.7.15, as this is written) with some testing with Python 3.6 & 3.7. We are using both wxPython 3.0.x and 4.0.x packages (as well as a bit of 2.8.x testing). There are some openGL issues with Python 2.7 and wxPython 4.0.x (at least on Windows) so we recommend wxPython 4.0.x only with Python 3.6+.