wiki:PythonPackages

Version 8 (modified by toby, 4 years ago) (diff)

--

Python Packages Required in GSAS-II

GSAS-II requires that you install Python 2.7.x or >=3.6 on your computer as well as a number of required Python packages.

We provide a single-file install distribution for (Windows, Mac OS X and Linux) that installs Python, the required packages and then downloads the latest version of GSAS-II.

Some users may prefer to install Python themselves. There are many distributions of Python available, but the easiest way to obtain Python with the required packages is to install the Anaconda (or Canopy) distributions, as described in the platform-specific installation instructions (Windows, Mac OS X or Linux). Linux users have the additional option of using pre-built Python dists from Redhat, Ubuntu, etc. This can sometimes be required as some older or very new dists can have compatibility problems with Anaconda, etc.

At present, GSAS-II is being developed with Python version 2.7 (2.7.3 - 2.7.13, as this is written) and is also getting limited testing with Python 3.6. We are waiting for Anaconda to provide WxPython 4.0 packages before making a major transition to Python 3.