Changes between Version 8 and Version 9 of PythonPackages

Oct 26, 2018 11:08:36 AM (4 years ago)



  • PythonPackages

    v8 v9  
    11= Python Packages Required in GSAS-II =
    3 GSAS-II requires that you install Python 2.7.x or >=3.6 on your computer as well as a number of
    4 [ required Python packages].
     3GSAS-II requires that you have Python 2.7.x or Python 3.6 or later installed on your computer. Also, GSAS-II requires a a number of Python packages,
     4[ as listed here].
    66We provide a single-file install distribution for ([InstallWindows Windows], [InstallMac Mac OS X] and [InstallLinux Linux]) that installs Python, the required packages and then downloads the latest version of GSAS-II.
    99There are many distributions of Python available, but the easiest way to obtain Python with the required packages is to install the Anaconda (or Canopy) distributions, as described in the platform-specific installation instructions ([InstallWindows Windows], [InstallMac Mac OS X] or [InstallLinux Linux]). Linux users have the additional option of using pre-built Python dists from Redhat, Ubuntu, etc. This can sometimes be required as some older or very new dists can have compatibility problems with Anaconda, etc.
    11 At present, GSAS-II is being developed with Python version 2.7 (2.7.3 - 2.7.13, as this is written) and is also getting limited testing with Python 3.6. We are waiting for Anaconda to provide !WxPython 4.0 packages before making a major transition to Python 3.
     11At present, GSAS-II is being developed with Python version 2.7 (up to 2.7.15, as this is written) with some testing with Python 3.6 & 3.7. We are using both wxPython 3.0.x and 4.0.x packages (as well as a bit of 2.8.x testing). There are some openGL issues with Python 2.7 and wxPython 4.0.x (at least on Windows) so we recommend wxPython 4.0.x only with Python 3.6+.