Changes between Version 15 and Version 16 of InstallLinux-prev


Ignore:
Timestamp:
Nov 1, 2016 4:35:43 PM (5 years ago)
Author:
toby
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • InstallLinux-prev

    v15 v16  
    1111You may instead wish to use distribution-supplied builds of Python and packages. Be sure to use Python 2.7. You will have to do this for 32-bit Linux. Also, if you want to build the binary files, you will need to install gfortran (see "Compiling Fortran Code" below).
    1212
    13 == Overview ==
     13=== Overview ===
    1414
    1515Before you can install or use GSAS-II you will need two software packages installed: python and subversion. Installation of subversion is usually trivial with the distributed package managers, but python may be more complex, since we require several additional [PythonPackages Python packages for GSAS-II]. Instructions are provided below for Ubuntu on how to do this. An alternative to this is to install a package with Python and a bunch of commonly needed packages. We have been recommending the free Enthought Python Distribution (EPDfree), but that is being replaced by a new product !CanopyExpress, which we have not tried yet. We develop GSAS-II ourselves using the commercially supported version, the [http://www.enthought.com/products/epd.php Enthought Python Distribution (EPD)], which is being replaced by Canopy, which we have also not tried yet. As I write this, the 64-bit EPDfree for linux is still available at [https://s3.amazonaws.com/storage.enthought.com/installers/epd_free-7.3-2-rh5-x86_64.sh this link] from this page, https://www.enthought.com/repo/free/.
    1616Alternatives include [http://www.pythonxy.com/ Python(x,y)] or [http://www.activestate.com/activepython ActiveState ActivePython]. We simply have not tried the latter two, but if you do, make sure that you install all the [PythonPackages required Python packages].
    1717
    18 == Simplified Installation ==
     18=== Simplified Installation ===
    1919
    2020 1. Install subversion
     
    5757If you need to change any options, type "{{{scons help}}}" to see a list of the possible command-line arguments and the values for the options. For testing, help can be used with command-line options to see how they will change the variables. 
    5858
     59= Notes for various Linux dists =
    5960
    6061== Fedora 18 Install ==