Description: Description: Description: GSAS-II logoHelp for GSAS-II

This is where to find help on various GSAS-II windows and plots. Note that GSAS-II operates with four windows: the main GSAS-II data tree window, which provides a hierarchical view of the current project; the GSAS-II data editing window, which shows the contents of a particular section of the project, where values can be examined and changed; the GSAS-II Plots window, which shows graphical representations of the results; and the console which has printout information that can be selected, cut & pasted into a document.

 

GSAS-II tutorials:

Starting GSAS-II

2-D Image calibration

2-D Image integration

Powder pattern peak picking, fitting and indexing

Lab X-ray powder pattern Rietveld refinement (future)

CW Neutron powder pattern Rietveld refinement (future)

Synchrotron X-ray powder pattern Rietveld refinement (future)

Crystal structure drawing (balls & sticks, etc.) (future)

Crystal structure drawing (polyhedra) (future)

Distance/Angle/Torsion calculations(future)

Charge flipping structure solution(future)

etc., etc.



1. GSAS-II data tree

This is a hierarchical view of the data items in your GSAS-II project (name.gpx). Clicking on any item in the tree opens a window where information in that item can be viewed or edited. For example, the "Sample Parameters" item under a ‘PWDR’ entry contains information about how data were collected, such as the sample temperature (see below). The arrow keys (up & down) move the selection to successive entries in the data tree; both the data window and the associated plot (if any) will change.

What can I do here?

The menus associated with this window provide access to many features of GSAS-II, as outlined below:

1.      Menu ‘File’ –

a.       Open project… - Open a previously saved GSAS-II project file (name.gpx). If you currently have a project file open, you are asked if it is OK to over write it; Cancel will cancel the process. NB: you may open a backup gpx file (e.g. name.bak3.gpx) to recover a previous version of your project. Remember to Save As… to e.g. name.gpx to overwrite the current version. Otherwise you may get backups of your backup file (e.g. name.bak3.bak0.gpx, etc.).

b.      Save project – Save the current project. If a file name is shown after ‘Loaded Data:’ in the data tree, it will be saved there. Otherwise, you will be prompted for a new name in a file dialog (you may change directory as well). If the file exists, you will be asked if it OK to overwrite.

c.       Save As… - Save the current project to a new file. A file dialog will be shown to enter the name (and change directory if desired). If the file exists, you will be asked if it OK to overwrite.

d.      Close project – Close the current project; you will be asked if you want to save it first.

e.       Exit – Exit the GSAS-II program; if there is a current project you will be asked if you want to save it first. Pressing the red X in the upper right (Windows) also exits (no save option) GSAS-II; useful for escaping from GSAS-II if needed.

2.      Menu ‘Data’ –

a.       Read powder data… - Read in powder diffraction patterns (multiple patterns can be selected). GSAS-II can read most of the old GSAS powder format files with the position in centidegrees 2-theta. It can also read “xye” format files used by topas where the position is in degrees 2-theta. As each file is read, an old GSAS style “instrument parameter file” is searched for; if not found a CuKa laboratory data set is assumed.

b.      Read image data… - Read in 2-D powder diffraction images (multiple patterns can be selected). GSAS-II can read many different image file formats including MAR345 files, Quantum ADSC files, and tiff files from Perkin-Elmer, Pilatus, and GE. Although many of these formats have data fields that should contain relevant information for the exposure (e.g. wavelength), these are rarely filled in correctly by the data acquisition software. Thus, you should have separately noted this information as it will be needed

c.       Read Powder Pattern Peaks… - Read in a list of powder pattern peak positions as either a d-spacing table or a set of 2Q positions; these can be used in GSAS-II powder pattern indexing.

d.      Read single crystal data… -

e.       Sum powder data -

f.       Sum image data -

g.      Add phase – This begins the creation of a new phase in the data tree (under Phases). You are first prompted in a dialog box for a name to be assigned to the new phase. Then the General tab is opened for this phase; you should first select the phase type, enter the space group symbol and then lattice parameters. Note that nonstandard space group symbols are permitted; there must be spaces between the axial fields (e.g. use ‘P n a 21’ not ‘Pna21’).

h.      Delete phase – This will remove a phase from the data tree. A dialog box will present the list of phases; pick one (or more) to delete.

i.        Rename data – This might be a bad idea!!

j.        Delete data – This will remove an item from the data tree. A dialog box with a list of choices is presented.

3.      Menu ‘Calculate’ –

a.       Make new PDFs – This creates the pair distribution function (PDF) controls for each powder pattern selected in the dialog box. See PDF Controls for further directions.

b.      View LS parms – This shows a dialog box with all the parameters for your project; those to be refined are flagged ‘True’, otherwise ‘False’. Blanks indicate parameters that are not refinable. The total number of refined parameters is also shown at the top of the list. The value of each parameter is also given. The parameter names are of the form ‘p:h:name:id’ where ‘p’ is the phase index, ‘h’ is the histogram index and ‘id’ is the item index (if needed). Indexes all begin with ‘0’ (zero). Note that for atom positions the value is not a refinable parameter, but the shift in the value is. Position names are, e.g. ‘0::Ax:0’ for the x-position of the zeroth atom in the zeroth phase while shift names have a ‘d’ in then, e.g. ‘0::dAx:0’.

c.       Refine – This performs the refinement (Pawley/Rietveld or single crystal) according to the controls set in the Controls data tree item.

d.      Sequential refine – This starts a sequential refinement with the data sets selected in the Controls data tree item.

4.      Menu ‘Import’ –

a.       Import Phase (specific) -

1.      Import Phase GSAS.EXP… - This reads one phase from a GSAS experiment file (name.EXP). The file name is found in a directory dialog; you can change directories as needed. Only .EXP (or .exp) file names are shown. If the selected file has more than one phase, a dialog is shown with the choices; only one can be chosen. If you want more than one, redo the Import Phase GSAS.EXP command. After selecting a phase, a dialog box is shown with the proposed phase name. You can change it if desired.

2.      Import Phase PDB… - This reads the macromolecular phase information from a Protein Data Base file (name.PDB or name.ENT). The file name is found in a directory dialog; you can change directories as needed. Only .PDB or .ENT file names are shown. Be careful that the space group symbol on the ‘CRYST1’ record in the PDB file follows the GSAS-II conventions (e.g. with spaces between axial fields). A dialog box is shown with the proposed phase name. You can change it if desired.

3.      Import Phase CIF… This reads one phase from a Crystallographic Information File (name.CIF). The file name is found in a directory dialog; you can change directories as needed. Only .CIF (or .cif) file names are shown. If the selected file has more than one phase, a dialog is shown with the choices; only one can be chosen. If you want more than one, redo the Import Phase CIF command. After selecting a phase, a dialog box is shown with the proposed phase name. You can change it if desired.

4.      Import Phase GSAS-II gpx This reads one phase from a GSAS-II project file (name.GPX). The file name is found in a directory dialog; you can change directories as needed. Only .GPX (or .gpx) file names are shown. If the selected file has more than one phase, a dialog is shown with the choices; only one can be chosen. If you want more than one, redo the Import Phase GSAS-II gpx command. After selecting a phase, a dialog box is shown with the proposed phase name. You can change it if desired.

b.      Import Powder Pattern… -

c.       Import HKLs… -

5.      Menu ‘Export’ –

a.       Export Powder Patterns… -

b.      Export All Peak Lists… -

c.       Export HKLs… -

d.      Export PDF… -

e.       Export Phase… -

f.       Export CIF… -



2. GSAS-II Data Editing Window

Different information is displayed in the Data Editing Window, depending on which section of the data tree is selected. For example, clicking on the "Notebook" entry of the tree brings up the Notebook editing window described below.

Notebook

This window provides a place for you to enter whatever text commentary you wish. Each time you enter this window, a date/time entry is provided for you. A possibly useful technique is to select a portion of the console window after a refinement completes (it will contain refinement results with residuals, new values & esds) and paste it into this Notebook window so it becomes a part of your project file.

Controls

This window provides the main controls for the major calculations in GSAS-II. At present only Refinement Controls are presented.

Two of the main refinement tools are the fortran MINPACK lmdif and lmder algorithms wrapped in python as provided in the Scipy package and a third one is a python version utilizing only the numpy package. The purpose is to minimize the sum of the squares of M nonlinear functions in N variables by a modification of the Levenberg-Marquardt algorithm. The lmdif and lmder routines were written by Burton S. Garbow, Kenneth E. Hillstrom, Jorge J. More (Argonne National Laboratory, 1980). The python/numpy version was developed by us based on the material in Numerical Recipes (Press, Flannery, Teulosky & Vetterling) for the Levenberg-Marquardt algorithm.

What can I do here?

1.      Select whether the refinement uses ‘analytic Jacobian’, ‘analytic Hessian’ or ‘numeric’ derivatives. The last is slower and perhaps a bit less accurate, but may be needed if the analytic functions are not fully developed. The Jacobian matrix is shaped N x M (parameters x observations) and is much larger than the Hessian matrix which is shaped M x M (parameters x parameters). Generally use ‘analytic Hessian’ for routine work.

2.      Select ‘Min delta-M/M’ for convergence; the refinement will stop when the change in the minimization function is less than this value. Set Min delta-M/M = 1.0 to force just a single cycle to be performed. A value less than 10-4 (the default) generally gives no better result. The allowed range is 10-9 to 1.0.

3.      If ‘analytic Jacobean’ is chosen then select ‘Initial shift factor’ for the first cycle of refinement. This value is modified by the least squares routine. The allowed range is 10-5 to 100. Smaller values may be needed if your initial refinement trials immediately diverge, however make sure your starting parameter values are ‘reasonable’. The selected default (=1.0) normally gives good performance.

4.      If ‘analytic Hessian’ is chosen then select ‘Max cycles’, the maximum number of least squares cycles to be performed. Least squares cycles are determined by the number of times a new Hessian matrix is computes; the Levenberg-Marquardt algorithm may compute the function several times between cycles as it finds the optimal value of the Marquardt coefficient. Choices are given in the pull down selection; the default is 3 cycles.

5.      Select data for sequential refinement; the data sets may be done in ‘reverse order’.

Covariance

This window is blank; the GSASII Plots window ‘Covariance’ shows a graphical representation of the variance-covariance matrix

Constraints

This window shows the constraints to be used in a refinement. It is organized into three tabbed pages. ‘Phase constraints’ contain those involving parameters that describe aspects of the crystalline phases to be used in the refinement (e.g. atom coordinates, thermal motion and site fraction parameters). ‘Histogram/Phase constraints’ are those which describe aspects of the pattern that depend on both the phase and the data set used in the refinement (e.g. mstrain and crystallite size parameters). ‘Histogram constraints’ are those that depend only on the data set (e.g. profile coefficients U,V,W,X and Y).

What can I do here?

1.      Select the tab for the parameter types you wish to constrain. Each will have the same possibilities in the ‘Edit menu.

2.      Menu ‘Edit’ –

a.       Add Hold – select a parameter that you wish to remain fixed although other parameters of the same type may be selected as a group for refinement. For example, if the space group for a phase has a polar axis (e.g. the b-axis in P21), then one atom y-parameter is arbitrary and should be selected for a Hold to keep the structure from drifting up or down the y-axis during refinement. If selected, a dialog box will appear showing the list of available parameters; select one and then OK to implement it, Cancel will cancel the operation. The held parameter will be shown in the constraint window with the keyword ‘FIXED’. A Delete button can be used to remove it.

b.      Add equivalence – select a list of parameters that should have the same value (possibly with a non-unitary multiplier for some). Examples are a list of atoms with the same thermal motion Uiso, sets of profile coefficients U,V,W across multiple data sets. If selected, a dialog box will appear with a list of the available parameters. Select one and press OK; a second dialog box will appear with only those parameters that can be made equivalent to the first one. Choose those and press OK. Cancel in either dialog will cancel the operation. The equivalenced parameters will show as an equation of the form M1*P1+M2*P2=0; usually M1=1.0 and M2=-1.0, but can be changed via the ‘Edit’ button. The keyword ‘EQUIV’ marks it as an equivalence. A Delete button can be used to remove it.

c.       Add constraint – select a list of parameters whose sum (with possible non-unitary multipliers) is fixed. For example, the sum of site fractions for atoms on the same site could be fixed to unity. If selected, a dialog box will appear with a list of the available parameters. Select one and press OK; a second dialog box will appear with only those parameters that can be used in a constraint with the first one. Choose those and press OK. Cancel in either dialog will cancel the operation. The equivalenced parameters will show as an equation of the form M1*P1+M2*P2+…=C; the multipliers M1, M2, … and C can be changed via the ‘Edit’ button. The keyword ‘CONSTR’ marks it as a constraint. A Delete button can be used to remove it.

d.      Add function – this is very similar the “Add constraint” type except that the result of the sum can be varied in the refinement. The keyword ‘FUNCT’ marks it as a function; the ‘Refine?’ box indicates your choice to refine the result of the sum. A Delete button can be used to remove it.

Restraints

This window is empty

What can I do here?

Nothing just yet

Sequential refinement results

In this window is tabulated the results of your sequential refinement. The columns are the parameter names; the naming convention is ‘p:h:name:n’ where p is the phase number, h is the histogram number, name is the parameter name, and num (if needed) is the item number (e.g. atom number). The rows are the data sets used in the sequential refinement.

What can I do here?
 

Histograms

These are shown in the data tree with a prefix of ‘PWDR’, ’HKLF’, ‘IMG’, ‘PDF’ or ‘XXXX’ (future – restraints??) and usually a file name. These constitute the data sets (‘Histograms’) to be used by GSAS-II for analysis. Selection of these items does not produce any information in the data window but does display the data in the Plots Window. They are described below.

Powder Histograms - PWDR

When a powder diffraction data set (prefix ‘PWDR’) is selected from the data tree, a variety of subcategories in the tree are shown. The items that are shown depend on the data set type. Selecting a subcategory raises the window listed below.

What can I do here?

1.      Menu ‘Analysis’ –

a.       Analyze – this produces a ‘normal probability’ plot for the refinement result as bounded by the limits. The slope and intercept of the curve in the central region (-1 < D/s < 1) are shown on the plot status line. The slope is the square root of GOF for the best fit set of data points (~68% of the data).

Comments

This window shows whatever comment lines (preceded by “#”) found when the powder data file was read by GSAS-II. If you are lucky, there will be useful information here (e.g. sample name, date collected, wavelength used, etc.). If not, this window will be blank. The text is read-only in that anything you try to enter here is not saved.

Limits

This window shows the limits in position to be used in any fitting for this powder pattern. The ‘original’ values are obtained from the minimum & maximum values in the powder pattern. You can modify ‘changed’ as needed.

What can I do here?

1.      You can change Tmin and Tmax in the ‘changed’ row as needed. Use the mouse to select the value to be changed (the background on the box will be blue or have a black border or a vertical bar will appear in the value), then enter the new value and press Enter or click the mouse elsewhere in the Background window. This will set the new value.

2.      Modify the values of ‘changed’; this can be done on the plot by dragging the limit bars (left – vertical green dashed line, right – vertical red dashed line) into position. A left or right mouse click on a data point on the plot will set the associated limit. In either case the appropriate value on the ‘changed’ row will be updated immediately.

3.      Menu ‘File’ –

a.       Copy – this copies the limits shown to other selected powder patterns. If used, a dialog box (Copy Parameters) will appear showing the list of available powder patterns, you can copy the limits parameters to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation.

Background

This window shows the choice of background functions and coefficients to be used in fitting this powder pattern. There are three types of contributions available for the background:

1). A continuous empirical function (‘chebyschev’, ‘cosine’, ‘lin interpolate’, ‘inv interpolate’ & ‘log interpolate’). The latter three select fixed points with spacing that is either equal, inversely equal or equal on a log scale of the x-coordinate. The set of magnitudes at each point then comprise the background variables. All are refined when refine is selected.

2). A set of Debye diffuse scattering equation terms of the form:

                

where A,R & U are the possible variables and can be individually selected as desired; Q = 2p/d.

3). A set of individual Bragg peaks using the pseudo-Voigt profile function as their shapes. Their parameters are ‘pos’, ’int’, ‘sig’ & ‘gam’; each can be selected for refinement. The default values for sig & gam (=0.10) are for very sharp peaks, you may adjust them accordingly to the kind of peak you are trying to fit before trying to refine them.

What can I do here?

1.      Menu ‘File’ –

a.       Copy – this copies the background parameters shown to other selected powder patterns. If used, a dialog box (Copy Parameters) will appear showing the list of available powder patterns, you can copy the background parameters to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation.

b.      Copy flags this copies only the refinement flags shown to other selected powder patterns. If used, a dialog box (Copy Refinement Flags) will appear showing the list of available powder patterns, you can copy the refinement flags to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation.

2.      You can select a different Background function from the pull down tab.

3.      You can choose to refine/not refine the background coefficients.

4.      You can select the number of background coefficients to be used (1-36).

5.      You can change individual background coefficient values. Enter the value then press Enter or click the mouse elsewhere in the Background window. This will set the new value.

6.      You can introduce one or more Debye scattering terms into the background. For each one you should enter a sensible value for ‘R’ – an expected interatomic distance in an amorphous phase is appropriate. Select parameters to refine; usually start with the ‘A’ coefficients.

7.      You can introduce single Bragg peaks into the background. For each you should specify at least the position. Select parameters to refine; usually start with the ‘int’ coefficients.

Instrument Parameters

This window shows the instrument parameters for the selected powder data set.

What can I do here?

1.      Menu ‘Operations’ –

a.       Load profile… - loads a GSAS-II instrument parameter file (name.instprm), replacing the existing instrument parameter values. All refinement flags are unset.

b.      Save profile… - saves the current instrument parameter values in a simple text file (name.instprm); you will be prompted for the file name – do not change the extension. This file may be edited but heed the warning to not change the parameter names, the order of the parameter records or add new parameter records as this will invalidate the file. You may only change the numeric values if necessary. You can change or add comment records (begins with ‘#’).

c.       Reset profile – resets the values for the instrument parameters to the default values shown in parentheses for each entry.

d.      Copy – this copies the instrument parameters shown to other selected powder patterns. If used, a dialog box (Copy parameters) will appear showing the list of available powder patterns, you can copy the instrument parameters to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation. The copy will only work for instrument parameters that are commensurate with the one that is shown, e.g. single radiation patterns will not be updated from Ka1/Ka2 ones.

e.       Copy flags - – this copies the instrument parameter refinement flags shown to other selected powder patterns. If used, a dialog box (Copy refinement flags) will appear showing the list of available powder patterns, you can copy the instrument parameter refinement flags to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation. The copy will only work for instrument parameters that are commensurate with the one that is shown, e.g. single radiation patterns will not be updated from Ka1/Ka2 ones.

f.       Change radiation – this changes the radiation between single wavelength (e.g. for synchrotron source) and Ka1/Ka2 wavelength pairs (e.g. a laboratory tube source).

2.      You can change any of the profile coefficients

3.      You can choose to refine any profile coefficients. NB: In certain circumstances some choices are ignored e.g. Zero is not refined during peak fitting. Also some choices may lead to unstable refinement, e.g. Lam refinement and lattice parameter refinement. Examine the ‘Covariance’ display for highly correlated parameters.

Sample Parameters

This window show the various sample dependent parameters for this powder pattern. The presence of a refine button indicates which can be refined while others are fixed. All values can be changed in this window.

What can I do here?
1.      Menu ‘File’

a.       Copy – this copies the sample parameters shown to other selected powder patterns. If used, a dialog box (Copy parameters) will appear showing the list of available powder patterns, you can copy the sample parameters to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation.

b.      Copy flags - – this copies the sample parameter refinement flags shown to other selected powder patterns. If used, a dialog box (Copy refinement flags) will appear showing the list of available powder patterns, you can copy the sample parameter refinement flags to any or all of them; select ‘All’ to copy them to all patterns. Then select ‘OK’ to do the copy; ‘Cancel’ to cancel the operation.

Peak List

This window shows the list of peaks that will be used by the peak fitting refinement. It is filled by picking peaks in the powder pattern displayed in the GSASII Plots window as a sequence of ‘+’ marks.

What can I do here?
1.      Menu ‘Peak Fitting’ –
a.       UnDo – resets peak parameters, background and instrument parameter values varied in the last peak fitting refinement back to their original values. Use this to recover from a failed refinement. Note:  there is only a single level of recovery available.
b.      LSQ PeakFit – perform a least squares fit of the peaks in PeakList to the data. Any peak parameters, background parameters and instrument parameters with refine checked will be varied in this refinement. The refinement will proceed until convergence. We suggest you vary the intensity along with the background first (the default), then vary the position and instrument parameters after. The order will depend on how poor is the initial estimate of the instrument parameters (U, V, W, X, Y & SH/L). To determine how to proceed, examine in detail the powder pattern difference curve displayed in the GSASII Plots window. If individual peaks show peak widths that are widely different, their individual sigma and gamma parameters may be refined. If the refinement results in negative peak coefficients, these will be highlighted in red. If this happens, you should UnDo the refinement and reconsider your choice of parameters to be varied.
c.       LSQ one cycle – perform a single cycle of least squares refinement. This can be used in difficult cases to get a refinement started toward convergence.
d.      Reset sig and gam – this resets the values of sigma and gamma to those computed from the instrument parameters U, V, W, X & Y.
e.       Clear peaks – this removes all the peaks from the Peak List.
2.      You can add peaks to the Peak list using the mouse on the plot by: 1) position the pointer near to the top point on a peak, 2) press the left mouse button. The selected peak will be added to the Peak List in its correct sorted order and a blue vertical line will be plotted on that position. Be sure that the Zoom/Pan buttons are not selected on the Plot window. We recommend that you begin picking peaks from the right side of the pattern; that way the tool tip won’t be in your way as you select peaks.
3.      You can move a Peak List item using the mouse on the plot by: 1) position the pointer on the blue line for the peak you wish to move, 2) holding the left mouse button down, drag to the desired position & then release the button. The peak line will be drawn in the new position. Be sure that the Zoom/Pan buttons are not selected on the Plot window.

4.      You can change individual peak coefficient values. Enter the value then press Enter or Tab or click the mouse elsewhere in the Peak List window. This will set the new value.

5.      You can change the refine flags either by clicking on the box or by selecting one and then selecting the column (a single click on the column heading; column should show in blue). Then type ‘y’ to set the refine flags or ‘n’ to clear the flags.

6.      You can delete peaks in the Peak List by selecting rows (should appear in blue) and then pressing the Delete key. You can also delete peaks using the mouse on the plot by positioning the pointer on the blue line for the peak to be deleted and then pressing the right mouse button. The blue line should vanish and the corresponding peak will be removed from the Peak List. Be sure that the Zoom/Pan buttons are not selected on the Plot window.

Index Peak List

This window shows the list of peaks that will be used for indexing (see Unit Cells List). It must be filled before indexing can proceed. When indexing is completed, this display will show the resulting hkl values for every indexed reflection along with the calculated d-spacing (‘d-calc’) for the selected unit cell in Unit Cells List.

What can I do here?

1.      Menu ‘Operations’ – Load/Reload – loads the peak positions & intensities from the Peak List to make them available for the indexing routine. The d-obs is obtained from Bragg’s Law after applying the Zero correction shown on the Instrument Parameters table to the position shown here.

2.      You may deselect individual peaks from indexing by unchecking the corresponding ‘use’ box.

Unit Cells List

This window...

Reflection List

This window...

Single Crystal Histograms - HKLF

Pair Distribution Functions - PDF

PDF Controls

This window

I(Q), S(Q), F(Q) & G(R)

This window...

2-D Images – IMG

Image Controls

This window...

Image Masks

This window...

Phase Windows

When a phase is selected from the data tree, parameters are shown for that selected phase in a tabbed window. Clicking on each tab raises the windows listed below. Each tab is identified by the underlined phrase in the following:

General Phase Parameters

This gives overall parameters describing the phase such as the name, space group, the unit cell parameters and overall parameters for the atom present in the phase. It also has the controls for computing Fourier maps for this phase.

What can I do here?

1.      Menu ‘Compute’ – The compute menu shows computations that are possible for this phase.

a.       Fourier maps – compute Fourier maps according to the controls set at bottom of General page.

b.      Search maps – search the computed Fourier map. Peaks that are above ‘Peak cutoff’ % of the maximum will be found in this procedure; they will be printed on the console and will be shown in the ‘Map peaks’ page. This page will immediately be shown and the peaks will be shown on the structure drawing for this phase as white 3-D crosses.

2.      The items in the upper part of the General page that can be changed are Phase name, Phase type, Space group, unit cell parameters & refine flag. These are described in turn:

a.       Phase name – this is the name assigned to this phase. It should only be changed when the phase is initialized or imported.

b.      Phase type – this can only be set when there are no atoms in the Atoms page for this phase. Select it when the phase is initialized.

c.       Space group – this should be set when the phase is initialized; it can be changed later. Be careful about the impact on Atom site symmetry and multiplicity if you do. GSAS-II will recognize any legal space group symbol using the short Hermann-Mauguin forms; put a space between the axial fields (e.g. ‘F d 3 m’ not ‘Fd3m’). For space groups with a choice of origin (e.g. F d 3 m), GSAS-II always uses the 2nd setting where the center of inversion is located at the origin. The choice of space group will set the available unit cell parameters.

d.      Refine unit cell – set this flag to refine the unit cell parameters in a Rietveld or Pawley refinement. The actual parameters refined are the symmetry allowed terms (A0-A5) in the expression

e.       a, b, c, alpha, beta, gamma – lattice parameters; only those permitted by the space group are shown. The volume is computed from the values entered.

3.      If there are entries in the Atoms page then the Elements table is shown next on the General page; you may select the isotope (only relevant for neutron diffraction experiments). The density is computed depending on this choice, the unit cell volume and the atom fractions/site multiplicities in the entries on the Atoms page.

4.      Fourier map controls are shown at the bottom of the General page. A completed Rietveld or Pawley refinement is required before a Fourier map can be computed. Select the desired type of map, the source of the reflection set and the map resolution desired.

Data sets

 

What can I do here?

 

Atom Parameters

What can I do here?

Texture Parameters

What can I do here?

Draw Options

What can I do here?

Draw Atoms

This gives a list of the atoms and bonds that are to be rendered as lines, van der Waals radii balls, sticks, balls & sticks, ellipsoids & sticks or polyhedra. There are two menus for this tab; Edit allows modification of the list of atoms to be rendered and Compute gives some options for geometric characterization of selected atoms.

What can I do here?

1.      Atom Selection from table: select individual atoms by a left click of the mouse when pointed at the left most column (atom numbers) of the atom display; hold down the Ctrl key to add to your selection; a previously selected atom will be deselected. A selected atom will be highlighted (in grey) and the atom will be shown in green on the plot. Selection without the Ctrl key will clear previous selections. A double left click in the (empty) upper left box will select or deselect all atoms.

2.      Atom Selection from plot: select an atom by a left click of the mouse while holding down the Shift key and pointed at the center of the displayed atom, it will turn green if successful and the corresponding entry in the table will be highlighted (in grey); any previous selections will be cleared. To add to .your selection use the right mouse button (Shift down); if a previously selection is reselected it is removed from the selection list. NB: beware of atoms that are hiding behind the one you are trying to select, they may be selected inadvertently. You can rotate the structure anytime during the selection process.

3.      Double left click a Name, Type and Sym Op column heading: a dialog box is shown that allows you to select all atoms with that characteristic. For example, selecting the Type column will show all the atom types; your choice will then cause all those atoms to be selected.

4.      Double left click a Style, Label or Color column: a dialog box is shown that allows you to select a rendering option for all the atoms. For Color a color choice dialog is displayed that covers the entire color spectrum. Choose a color by any of the means available, press the “Add to Custom Colors”, select that color in the Custom colors display and then press OK. NB: selecting Color will make all atoms have the same color and for Style “blank” means the atoms aren’t rendered and thus the plot will not show any atoms or bonds!

5.      Menu ‘Edit’ - The edit menu shows operations that can be performed on your selected atoms. You must select one or more atoms before using any of the menu items.

a.       Atom style – select the rendering style for the selected atoms

b.      Atom label – select the item to be shown as a label for each atom in selection. The choices are: none, type, name or number.

c.       Atom color – select the color for the atom; a color choice dialog is displayed that covers the entire color spectrum. Choose a color by any of the means available, press the “Add to Custom Colors”, select that color in the Custom colors display and then press OK.

d.      Reset atom colors – return the atom color back to their defaults for the selected atoms.

e.       View point – position the plot view point to the first atom in the selection.

f.       Add atoms – using the selected atoms, new ones are added to the bottom of the list after applying your choice of symmetry operator and unit cell translation selected via a dialog display. Duplicate atom positions are not retained. Any anisotropic thermal displacement parameters (Uij) will be transformed as appropriate.

g.      Transform atoms – apply a symmetry operator and unit cell translation to the set of selected atoms; they will be changed in place. Any anisotropic thermal displacement parameters (Uij) will be transformed as appropriate.

h.      Fill CN-sphere – using the atoms currently in the draw atom table, find all atoms that belong in the coordination sphere around the selected atoms via unit cell translations. NB: symmetry operations are not used in this search.

i.        Fill unit cell - using the atoms currently selected from the draw atom table, find all atoms that fall inside or on the edge/surface/corners of the unit cell. This operation is frequently performed before Fill CN-sphere.

j.        Delete atoms – clear the entire draw atom table; it is then refilled from the Atoms table. You should do this operation after any changes in the Atoms table, e.g. by a structure refinement.

6.      Menu ‘Compute’ - The compute menu gives a choice of geometric calculations to be performed with the selected atoms. You must select the appropriate number of atoms for these to work and the computation is done for the atoms in selection order.

a.       Dist. Ang. Tors. when 2-4 atoms are selected, a distance, angle or torsion angle will be found for them. The angles are computed for the atoms in their selection order. The torsion angle is a right hand angle about the A2-A3 vector for the sequence of atoms A1-A2-A3-A4. An estimated standard deviation is given for the calculated value if a current variance-covariance matrix is available. The result is shown on the console window; it may be cut & pasted to another application (e.g. Microsoft Word).

b.      Best plane – when 4 or more atoms are selected, a best plane is determined for them. The result is shown on the console window; it may be cut & pasted to another application (e.g. Microsoft Word). Shown are the atom coordinates transformed to Cartesian best plane coordinates where the largest range is over the X-axis and the smallest is over the Z-axis with the origin at the unweighted center of the selection. Root mean square displacements along each axis for the best plane are also listed. The Z-axis RMS value indicates the flatness of the proposed plane. NB: if you select (e.g. all) atoms then Best plane will give Cartesian coordinates for these atoms with respect to a coordinate system where the X-axis is along the longest axis of the atom grouping and the Z-axis is along the shortest distance. The origin is at the unweighted center of the selected atoms.

Pawley reflections

This gives the list of reflections used in a Pawley refinement and can only be seen if the phase type is ‘Pawley’ (see General).

What can I do here?

1.      Menu ‘Operations’

a.       Pawley create – this creates a new set of Pawley reflections, over writing any preexisting Pawley set. They are generated with d-spacings larger than the limit set as ‘Pawley dmin’ in the General tab for this phase. By default the refine flags are not set and the Fsq(hkl) = 100.0.

b.      Pawley estimate – this attempts an estimate of Fsq(hkl) from the peak heights of the reflection as seen in the 1st powder pattern of those selected in the Data tab.

c.       Pawley delete – this clears the set of Pawley reflections.

2.      You can change the refine flags either by clicking on the box or by selecting one and then selecting the column (a single click on the column heading). Then type ‘y’ to set the refine flags or ‘n’ to clear the flags. You should deselect those reflections that fall below the lower limit or above the upper limit of the powder pattern otherwise you may have a singular matrix error in your Pawley refinement.

3.      You can change the individual Fsq(hkl) values by selecting it, typing in the new value and then pressing enter or selecting somewhere else in the table.

 

Map peaks

This gives the list (magnitude, x y & z) of all peaks found within the unit cell from the last Fourier map search sorted in order of decreasing peak magnitude. The crystal structure plot shows each peak position as a white 3-D cross.

What can I do here?

1.      Select a peak with a left click on the left hand row number, hold Ctrl key down to add more peaks to your selection. Each peak selected will show as a green 3-D cross on the crystal structure plot.

2.      Menu ‘Map peaks’  

a.       Move peaks – this copies selected peaks to the Atoms list and the Draw Atoms list. They will be appended to the end of each list each with the name ‘UNK’ and the atom type as ‘H’. They will also be drawn as small white spheres at their respective positions in the structure drawing. You should next go to the Atoms page and change the atom type to whatever element you desire; it will be renamed automatically.

b.      Clear peaks – this deletes all the peaks in the map peak list; they are also removed from the crystal structure drawing plot.



3. GSAS-II Plots Window

This window presents all the graphical material as a multipage tabbed set of plots utilizing the matplotlib python package. Each page has a tool bar (at bottom in Windows) with the controls

Description: Description: Description: D:\pyGSAS\help\graphbar.jpg

These are Home, Back, Forward, Pan, Zoom, Save and Help, respectively.

 

Below the toolbar may be a status bar that on the left may show either an instruction for a keyed input or a pull down selection of keyed input; on the right may be displayed position dependent information that is updated as the mouse is moved over the plot region.

 

The specific types of plots that are pages in the GSASII Plots windows are next.

Powder Patterns

The powder patterns that are part of your project are shown on this page. They can be displayed as a stack of powder patterns, just a single pattern or as a contour image of the peak intensities. What can be done here will depend on which is displayed and on which item in the GSAS-II data tree you have selected.

What can I do here?

1.      Move the mouse cursor across the plot, the plot status line will show the cursor position in 2Q, d-spacing and the intensity. For a q-plot, q is shown instead of 2Q.

2.      On the plot status line ‘key press’ – you can either press the key on the key board or select from the pull down menu. For line plots:

a.       l: offset left – for a waterfall plot of multiple powder profiles, increase the offset to the left. Does not apply if only one pattern.

b.      r: offset right - for a waterfall plot of multiple powder profiles, increase the offset to the left. Does not apply if only one pattern.

c.       d: offset down - for a waterfall plot of multiple powder profiles, increase the offset down. Does not apply if only one pattern.

d.      u: offset up - for a waterfall plot of multiple powder profiles, increase the offset up. Does not apply if only one pattern.

e.       o: reset offset - for a waterfall plot of multiple powder profiles, reset to no offset. Does not apply if only one pattern.

f.       n: log(I) on/off – changes the y-axis to be the log10 of the intensity; difference curve is not shown for log(I) on.

g.      c: contour on/off – if multiple powder profiles, then a contour plot is shown of the observed intensities. All data sets must be the same length as the first one to be included in the contour plot.

h.      q: toggle q plot – changes the x-axis from 2Q to q=2p/d. This will put multiple powder patterns taken at different energies on the same x-axis scale.

i.        s: toggle single plot – for multiple powder profiles, this will show only the one selected from the data tree. The offset options are not active.

j.        w: toggle divide by sig – for the pattern selected from the data tree, this will divide the observed, calculated and difference curves by the esd for the data points. Other data sets are not shown.

k.      +: no selection - for multiple powder profiles, only the observed curve is shown.

3.      For contour plots the status line ‘key press’ options are different:

a.       d: lower contour max – this lowers the level chosen for the highest contour color.

b.      u: raise contour max – this raises the level chosen for the highest contour color

c.       i: interpolation method – this changes the method used to represent the contours. If selected a dialog box appears with all the possible choices. Default is ‘nearest’; the other useful choice is ‘bilinear’, this will smooth out the contours.

d.      s: color scheme – this changes the color scheme for the contouring. Default is ‘Paired’, black/ white options are ‘Greys’ and ‘binary’ (for black on white) or ‘gray’ (for white on black). Others can be very colorful (but not useful)!

e.       c: contour off/on – this turns off contouring and returns to a waterfall plot with any offsets applied.

4.      Depending on the item chosen for the selected powder pattern in the data tree, the mouse buttons have different actions:

a.       Limits - Modify the values of ‘changed’; this can be done on the plot by dragging the limit bars (left – vertical green dashed line, right – vertical red dashed line) into position. A left or right mouse click on a data point on the plot will set the associated limit. In either case the appropriate value on the ‘changed’ row will be updated immediately.

b.       

 

Covariance

The variance-covariance matrix as a color coded array is shown on this page. The color bar to the right shows the range of covariances (-1 to 1) and corresponding colors. The parameter names are to the right and the parameter numbers are below the plot.

What can I do here?

1.      Move the mouse cursor across the plot. If on a diagonal cell, the parameter name, value and esd is shown both as a tool tip and in the right hand portion of the status bar. If the cursor is off the diagonal, the two parameter names and their covariance are shown in the tool tip and the status bar.

2.      Use the Zoom and Pan buttons to focus on some section of the variance-covariance matrix.

3.      Type ‘s’ – A color scheme selection dialog is shown. Select a color scheme and press OK, the new color scheme will be plotted. The default is ‘RdYlGn’.

Structure Factors

This plot shows...

What can I do here?

Powder Lines

This plot shows the line positions for the peak list

 

Powder Patterns

This plot shows….

What can I do here?

Peak Widths

This plot shows the contributions to the powder pattern peak widths as Dd/d (= Dq/q) vs q(=2p/d) from the Gaussian and Lorentzian parts of the profile function. The computed curves are based on the values of U, V, W, X and Y shown in the Instrument Parameters window in parentheses. These are the values for the instrument contribution that were set when the powder pattern was first read in to GSAS-II. If individual peak fitting has been performed, the values of ‘sig’ & ‘gam’ for the peaks are plotted as ‘+’; these are computed from the fitted values of U, V, W, X and Y as well as any sig or gam individually refined.

Texture

This plot shows...

What can I do here?

Sequential refinement

This plot shows the variation of the selected parameters with respect to the data sequence number.

What can I do here?

2D Powder Image

This plot shows...

What can I do here?

2D Integration

This plot shows...

What can I do here?

2D Transformed Powder Image

This plot shows...

What can I do here?

Mustrain

This plot shows...

What can I do here?

Size

This plot shows...

What can I do here?

Preferred Orientation

This plot shows...

What can I do here?

Crystal Structure

This plot shows the atoms of the crystal structure. The atoms are displayed according to the controls in the Draw Options page.

What can I do here?

 

 


Last modified: Tue Nov 22 13:19:47 CST 2011