Changeset 564


Ignore:
Timestamp:
Apr 20, 2012 11:54:15 AM (10 years ago)
Author:
toby
Message:

change opengl install to work locally if needed

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/GSASII.py

    r547 r564  
    3333    print('*******************************************************')
    3434    def install_with_easyinstall(package):
    35         easy_install.main(['-f',ospath.split(__file__)[0],package])
     35        try:
     36            print "trying a system-wide PyOpenGl install"
     37            easy_install.main(['-f',ospath.split(__file__)[0],package])
     38            return
     39        except:
     40            pass
     41        try:
     42            print "trying a user level PyOpenGl install"
     43            easy_install.main(['-f',ospath.split(__file__)[0],'--user',package])
     44            return
     45        except:
     46            print "Install of '+package+' failed. Please report this information:"
     47            import traceback
     48            print traceback.format_exc()
     49            sys.exit()
    3650    from setuptools.command import easy_install
    3751    install_with_easyinstall('PyOpenGl')
Note: See TracChangeset for help on using the changeset viewer.