Changeset 4742


Ignore:
Timestamp:
Jan 7, 2021 6:12:11 PM (8 months ago)
Author:
toby
Message:

deal with install python not matching target system

File:
1 edited

Legend:

Unmodified
Added
Removed
  • install/g2complete/src/bootstrap.py

    r4739 r4742  
    2222allBinaries = False        # if True, causes all binaries to be installed
    2323                           #--> True: -allbinaries or -server
    24 numpyVersion=None          # if specified, gives a specific numpy version to use (such as 1.18)
     24
     25npVersion=None          # when set, gives a specific numpy version to use (such as 1.18)
    2526                           # for selecting a set of binaries to use
    2627                           #--> Set by: -binary=
     28
     29pyVersion=None             # when set, gives a specific Python version to use (such as 3.7)
     30                           # for selecting a set of binaries to use
     31                           #--> Set by: -binary=
     32
    2733
    2834for a in sys.argv[1:]:
     
    3844        allBinaries = True
    3945    elif 'binary' in a.lower():
    40         numpyVersion = a.split('=')[1]
     46        vers = a.split('=')[1].split(',')
     47        npVersion = vers[0]
     48        if len(vers) > 1:
     49            pyVersion = vers[1]
    4150        skipInstallChecks = True
    4251        if sys.platform.startswith('win'): showWXerror = True
     
    5867    --help        this message
    5968    --nonet       skip steps requiring internet
    60     --binary=ver  specifies a specific numpy binary directory to use (such as
    61                   --binary=1.18); turns on --noinstall and --noproxy
     69
     70    --binary=npver          specifies a specific numpy/python version to use in selecting
     71    --binary=npver,pyver    a binary directory to use ; turns on --noinstall and --noproxy
     72           (example --binary=1.18 or --binary=1.18,3.7)
     73           turns on --noinstall and --noproxy
    6274''')
    6375    sys.exit()
     
    587599        msg = 'Binary load failed. Subversion problem? Please seek help'
    588600        BailOut(msg)
    589 elif numpyVersion:
    590     binaryVersion = GSASIIpath.GetBinaryPrefix()+'_n'+numpyVersion
     601elif npVersion:
     602    binaryVersion = GSASIIpath.GetBinaryPrefix(pyver)+'_n'+npVersion
    591603    print('Load binaries from '+binaryVersion)
    592604    if not GSASIIpath.svnSwitchDir('bindist','',g2home+ 'Binaries/'+binaryVersion,None,True):
Note: See TracChangeset for help on using the changeset viewer.