Changeset 4408


Ignore:
Timestamp:
Apr 22, 2020 11:17:11 AM (18 months ago)
Author:
toby
Message:

warning for MPL 3.1 & 3.2

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/GSASIIplot.py

    r4404 r4408  
    665665        page = G2Plot3D(self.nb)
    666666        self._addPage(name,page)
     667        mplv = mpl.__version__.split('.')
     668        if mplv[0] == '3' and (mplv[1] == '1' or mplv[1] == '2'): # patch for bad MPL 3D
     669
     670            G2G.G2MessageBox(self,'3D plots with Matplotlib 3.1.x and 3.2.x are distorted, we suggest regressing to MPL 3.0.3 until 3.3.x or later is available.. You have '+mpl.__version__,
     671                                 'Avoid Matplotlib 3.1 & 3.2')
    667672        return page.figure
    668673       
Note: See TracChangeset for help on using the changeset viewer.