Changeset 4261 for install


Ignore:
Timestamp:
Jan 19, 2020 10:07:35 AM (21 months ago)
Author:
toby
Message:

Last(?) updates to mac/linux install

Location:
install/g2complete
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • install/g2complete/post-link.sh

    r4260 r4261  
    33echo $PREFIX/bin/python
    44# "install" the GSAS-II package (create shortcuts, byte-compile...)
    5 $PREFIX/bin/python $PREFIX/GSASII/bootstrap.py --nonet > /tmp/bootstrap1.log 2> $PREFIX/.messages.txt
     5$PREFIX/bin/python $PREFIX/GSASII/bootstrap.py --nonet > /tmp/bootstrap1.log 2>> $PREFIX/.messages.txt
    66# Now try to update to latest GSAS-II version (will fail if no network)
    77$PREFIX/bin/python $PREFIX/GSASII/bootstrap.py --noinstall > /tmp/bootstrap2.log 2>> $PREFIX/.messages.txt
  • install/g2complete/src/bootstrap.py

    r4258 r4261  
    6868        dlg.Destroy()
    6969    else:
    70         print(msg,file=sys.stderr)
     70        print("BOOTSTRAP WARNING: ",file=sys.stderr)
     71        print(msg.replace('\n',' '),file=sys.stderr)
     72        print(" Recreate this using command: {} {} {}".format(
     73            os.path.abspath(sys.executable),
     74            os.path.abspath(os.path.expanduser(__file__)),
     75            ' '.join(sys.argv[1:]),
     76        ),file=sys.stderr)
    7177    sys.exit()
    7278       
     
    406412            if os.path.exists(os.path.join(path2GSAS2,"makeBat.py")):
    407413                msg += '\n\nGSAS-II failed to be updated. A likely reason is a network access'
    408                 msg += '\nproblem. If your web browser works, but the update did not.'
    409                 msg += '\nThe most common reason is you need to use a network proxy. Please'
     414                msg += '\nproblem. If your web browser works, but the update did not,'
     415                msg += '\nthe most common reason is you need to use a network proxy. Please'
    410416                msg += '\ncheck with a network administrator or use http://www.whatismyproxy.com/'
    411             else:               
     417            else:
     418                # this will happen only with initial installs where all files
     419                # are to be downloaded (not gsas2full or updates)
    412420                msg += '\n\n  *** GSAS-II failed to be installed. A likely reason is a network access'
    413421                msg += '\n  *** problem, most commonly because you need to use a network proxy. Please'
     
    427435    print('Loading all binaries with command...')
    428436    if not GSASIIpath.svnSwitchDir('AllBinaries','',g2home+ 'Binaries/',None,True):
    429         msg = 'Binary load failed'
     437        msg = 'Binary load failed. Subversion problem? Please seek help'
    430438        BailOut(msg)
    431439else:
     
    463471        msg += err
    464472    #print('\nAttempting to open a web page on compiling GSAS-II...')
    465     msg += '\n\nPlease see web page\nhttps://subversion.xray.aps.anl.gov/trac/pyGSAS/wiki/CompileGSASII'
     473    msg += '\n\nPlease see web page\nhttps://subversion.xray.aps.anl.gov/trac/pyGSAS/wiki/CompileGSASII if you wish to compile for yourself (usually not needed for windows and Mac, but sometimes required for Linux.)'
    466474    BailOut(msg)
    467475    #import webbrowser
Note: See TracChangeset for help on using the changeset viewer.