Changeset 1532 for install


Ignore:
Timestamp:
Oct 22, 2014 3:42:27 PM (7 years ago)
Author:
toby
Message:

allow bootstrap to work with old svn, as in 10.5

File:
1 edited

Legend:

Unmodified
Added
Removed
  • install/bootstrap.py

    r1358 r1532  
    6161    print 'Unidentifed platform -- you may need to run scons on fsource files'
    6262
    63 cmds = (
    64     ([svn, 'co', home+ 'trunk/', gsaspath, '--non-interactive', '--trust-server-cert'],'loading GSAS-II'),
    65 )
    66 
    67 for cmd,msg in cmds:
    68     print 70*'*'
    69     print msg + ' from ' + cmd[2]
    70     for item in cmd: print item,
    71     print ""
     63cmd = [svn, 'co', home+ 'trunk/', gsaspath, '--non-interactive', '--trust-server-cert']
     64msg = 'loading GSAS-II'
     65   
     66print 70*'*'
     67print msg + ' from ' + cmd[2]
     68for item in cmd: print item,
     69print ""
     70p = subprocess.call(cmd)
     71if p:
     72    print 'subversion returned an error; Retrying...'
     73    cmd = [svn, 'co', home+ 'trunk/', gsaspath]
    7274    p = subprocess.call(cmd)
    7375
Note: See TracChangeset for help on using the changeset viewer.