Changeset 1256


Ignore:
Timestamp:
Mar 19, 2014 4:35:25 PM (8 years ago)
Author:
vondreele
Message:

Added python version check; must be python 2.7!

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/GSASII.py

    r1243 r1256  
    5959    print('*******************************************************')         
    6060    sys.exit()
    61 
     61   
    6262# load the GSAS routines
    6363import GSASIIpath
     
    32673267    def OnInit(self):
    32683268        '''Called automatically when the app is created.'''
     3269        if '2.7' not in sys.version[:5]:
     3270            dlg = wx.MessageDialog(None,
     3271                'GSAS-II requires Python 2.7.x\n Yours is '+sys.version[:5],
     3272                'Python version error',  wx.OK)
     3273            try:
     3274                result = dlg.ShowModal()
     3275            finally:
     3276                dlg.Destroy()
     3277            sys.exit()
    32693278        self.main = GSASII(None)
    32703279        self.main.Show()
Note: See TracChangeset for help on using the changeset viewer.