Description: GSAS-II logoHelp for GSAS-II – Phase Tree Items and its Tab Sections

This is where to find help on the Phase Tree items in GSAS-II. Note that the window displayed for this page has multiple tabs. The help information is broken down by tab section.

7. Phase data tree items

When a phase is selected from the data tree, parameters are shown for that selected phase in a tabbed window. Clicking on each tab raises the windows listed below. Each tab is identified by the underlined phrase in the following:

General Phase Parameters

This gives overall parameters describing the phase such as the name, space group, the unit cell parameters and overall parameters for the atom present in the phase. It also has the controls for Pawley intensity extraction and for computing Fourier maps for this phase. It can also be used to compute new structures based on the unit cell and atom positions.

What can I do here?

1.     Menu ‘Compute’ – The compute menu shows computations that are possible for this phase.

a.     Fourier maps

compute Fourier maps according to the controls set at bottom of General page.

Search maps

search the computed Fourier map. Peaks that are above ‘Peak cutoff’ % of the maximum will be found in this procedure; they will be printed on the console and will be shown in the ‘Map peaks’ page. This page will immediately be shown and the peaks will be shown on the structure drawing for this phase as white 3-D crosses.

Charge flipping

This performs a charge flipping ab initio structure solution using the method of Oszlanyi & Suto (Acta Cryst. A60, 134-141, 2004). You will need to select a source for the reflection set and perhaps select an element for normalization by its form factor, a resolution limit (usually 0.5A) and a charge flip threshold (usually 0.1); these are found at the bottom of the General window. A progress bar showing the charge flip residual is shown while the charge flip is in operation. When the residual is no longer decreasing (be patient – it doesn’t necessarily fall continuously), press the Cancel button to stop the charge flipping. The resulting map will be positioned to properly place symmetry operators (NB: depends on the quality of the resulting phases), searched for peaks and the display shifts to Map peaks to show them.

Clear map

This clears any Fourier/charge flip map from memory; the Fourier map controls are also cleared.

Transform

This allows for a change in axes, symmetry or unit cell. It is also used to create a magnetic phase from a chemical (nuclear) phase. One important transformation that can be done here is for Origin 1 settings to Origin 2 (described below)

 

2.     The items in the upper part of the General page that can be changed are Phase name, Phase type, Space group, unit cell parameters & refine flag. These are described in turn:

a.     Phase name – this is the name assigned to this phase. It should only be changed when the phase is initialized or imported.

b.     Phase type – this can only be set when there are no atoms in the Atoms page for this phase. Select it when the phase is initialized.

c.     Space group – this should be set when the phase is initialized; it can be changed later. Be careful about the impact on Atom site symmetry and multiplicity if you do. GSAS-II will recognize any legal space group symbol using the short Hermann-Mauguin forms; put a space between the axial fields (e.g. ‘F d 3 m’ not ‘Fd3m’). For space groups with a choice of origin (e.g. F d 3 m), GSAS-II always uses the 2nd setting where the center of inversion is located at the origin. The choice of space group will set the available unit cell parameters.

d.     Refine unit cell – set this flag to refine the unit cell parameters in a Rietveld or Pawley refinement. The actual parameters refined are the symmetry allowed terms (A0-A5) in the expression

e.     a, b, c, alpha, beta, gamma – lattice parameters; only those permitted by the space group are shown. The volume  is computed from the values entered.

3.     If there are entries in the Atoms page then the Elements table is shown next on the General page; you may select the isotope (only relevant for neutron diffraction experiments). The density (just above the Elements) is computed depending on this choice, the unit cell volume and the atom fractions/site multiplicities in the entries on the Atoms page.

4.     Next are the Pawley controls.

a.     Do Pawley refinement? – This must be chosen to perform a Pawley refinement as opposed to a Rietveld refinement for this phase. NB: you probably should clear the Histogram scale factor refinement flag (found in Sample parameters for the powder data set) as it cannot be refined simultaneously with the Pawley reflection intensities.

b.     Pawley dmin – This is the minimum d-spacing to be used in a Pawley refinement. NB: be sure to set this to match the minimum d-spacing indicated by the powder pattern limits (see Limits for the powder data set).

c.     Pawley neg. wt. – This is the weight for a penalty function applied during a Pawley refinement on resulting negative intensities. Use with caution; initially try very small values (e.g. .01). A value of zero means no penalty is applied.

5.     Fourier map controls are shown next on the General page. A completed Rietveld or Pawley refinement is required before a Fourier map can be computed. Select the desired type of map, the source of the reflection set and the map resolution desired. The peak cutoff is defined as a percentage of the maximum and defines the lowest level considered in the peak search.

6.     Charge flip controls are below the Fourier map controls.

a.     Reflection set from – This is the source of structure factors to be used in a charge flip calculation. These may be either a single crystal data set, or structure factors extracted from a powder pattern via a Pawley refinement or a Rietveld refinement.

b.     Normalizing element – This is an element form factor chosen to normalize the structure factors before charge flipping. None (the default) can be selected from the lower right of the Periodic Table display shown when this is selected.

c.     Resolution – This is the resolution of the charge flip map; default is 0.5A. The set of reflections is expanded to a full sphere and zero filled to this resolution limit; this suite of reflections is then used for charge flipping.

d.     k-Factor – This is the threshold on the density map, all densities below this are charge flipped.

e.     k-Max – This is an upper threshold on the density may; all densities above this are charge flipped. In this way the “uranium solution” problem is avoided. Use k-Max = 10-12 for equal atom problems and larger for heavy atom ones.

7.     Monte Carlo/Simulated Annealing controls are at the bottom of the window. (Future capability & under development).

a.     Reflection set from – This is the source of structure factors to be used in a charge flip calculation. These may be either a single crystal data set, or structure factors extracted from a powder pattern via a Pawley refinement or a Rietveld refinement.

b.     d-min - This restricts the set of reflections to be used in the MC/SA run.

c.     MC/SA algorithm – This selects the type of jump to be used for each MC/SA trial.

d.     Annealing schedule – This selects the beginning MC/SA “temperature”, final “temperature”, slope and number of trials at each step.

e.     A-jump & B-jump – If the “Tremayne” algorithm is chosen these determine the jump components for each trial.

Origin 1 -> Origin 2 Transformations

An important transformation may be needed in certain cases when space groups that two alternate origin settings (listed here). These are centrosymmetric space groups where the highest symmetry point in the structure does not contain a center of symmetry. Origin 1 places the origin at the highest symmetry setting while Origin 2 places the origin at a center of symmetry (creating a -x,-y,-z symmetry operator, which means that reflection phases can only be 0 or π.) GSAS-II requires use of the Origin 2 settings because computations are much faster and simpler without complex structure factors. Alas, the literature contains a number of structures reported in Origin 1, where the origin choice may not be clearly communicated. (The CIF standard does not require that origin choice be indicated.) When a structure is imported that uses any of the space groups where an origin choice is possible, a message is shown in GSAS-II notifying the user that they must confirm that the origin choice is correct.

Example: An example of what can go wrong is illustrated with the structure of anatase. The space group is I 41/a m d. In Origin 1 the coordinates are:

Origin 1

atom

coordinates

Ti

0

0

0

O

0

0

0.208

and in Origin 2 the coordinates are:

Origin 2

atom

coordinates

Ti

0

1/4

-1/8

O

0

1/4

0.083

where the origin is shifted by (0,0.25,-0.125).

Since GSAS-II always the symmetry operators for Origin 2, if structure is input incorrectly with the coordinates set for Origin 1, there are several fairly obvious signs of problems: (1) the site symmetries and multiplicities are wrong, often giving an incorrect chemical formula, (2) the interatomic distances are incorrect, and (3) a plot of the structure is improbable. In this case incorrect multiplicities gives rise to a density of 7.9 g/cc, double the correct value. Impossible interatomic distances of 1.88Å for Ti-Ti, and 1.39Å for Ti-O are seen. The unit cell contents with the wrong space group operators is shown to the right.

With coordinates that match the space group operations, the correct Ti-O distances are 1.92Å and 1.97Å and the shortest Ti-Ti distance is 3.0Å. (Note that interatomic distances can be computed in GSAS-II using the Phase Atoms tab and the Compute/"Show Distances & Angles" menu item.)

Transform Origin: To transform a space group setting from Origin setting 1 to 2, use the Transform option in the Compute menu and then select the last option in the "Common transformations" pulldown menu, which will be setting 1->2 for space groups where both origins are available, as shown to the right. The transformation matrix will be set to the identity and the "V" vector will have the required origin shift loaded. Press OK. The changes can be seen by selecting the Atoms tab.


Data

Depending on the setting for preference variable SeparateHistPhaseTreeItem, these items may be displayed connected to data tree item “Hist/Phase” or may appear in the Data tab for each phase.

 

Note that GSAS-II has four types of controls/parameters:

·      Global: affects overall program function

·      Phase: includes atoms, lattice parameters, texture…

·      Histogram: includes instrument & sample parameters, data limits

·      Histogram/Phase. This controls which histograms are connected to each phase as well as specifies phase fractions, for powders: crystallite size, microstrain, preferred orientation, etc. If there are N used phases and M used histograms, there are N*M sets of Histogram/Phase controls/parameters.

 

This GUI section serves several purposes. It is used to link histograms to the selected phase and it allows the values and refinement flags to be set for the parameters that are defined for each histogram-phase pair, including: the phase fraction; the sample contribution to peak broadening: microstrain and crystallite size; a LeBail intensity extraction flag; hydrostatic/elastic strain shifts to lattice parameters; corrections to peak intensities due to experimental effects (preferred orientation, extinction and disordered solvents). It can also be used to show a graphical representation of an HAP parameter set.

 

For single crystal data, the only parameters are scale, extinction and disordered solvent; there is no Sample Parameters histogram scale factor.

 

Use flag

When the Use flag is selected, the currently selected phase is used to compute intensities as a contribution to the selected histogram (single-crystal histograms can be associated with only one phase; powder histograms can be linked to any number of phases). When not set, the phase is not present in the selected histogram. It is also possible to remove the reference to a histogram from a phase with the “Remove Histogram” item in the “Edit Phase” menu.

LeBail extraction

When this is selected, intensities are set to values that are best-fit using the LeBail intensity determination method, rather than are computed from the atomic information for the phase. Cycling this setting will reset LeBail extracted intensities to their default (F2 = 100).

Phase fraction

Used in powder histograms: a multiplier that determines the relative amount of the selected phase to a histogram. Note that when the histogram scale factor is varied, these values are on a relative scale. Conventional practice is to vary the scale factor and to not vary the phase fraction for one phase in a histogram. Do not refine the scale factor and all phase fractions unless a constraint is defined so the phase fractions add to 1.

Scale factor

Used for single crystal data only: relates F2obs to F2calc.

Crystallite size peak broadening

Is computed from size factor(s) in microns (10-6 m), with the Scherrer constant assumed as unity. Sizes can be computed in three ways: isotropic, uniaxial and ellipsoidal.

·      In isotropic broadening, crystallites are assumed to average as uniform in all directions and a single size value is supplied;

·      With uniaxial broadening, a preferred direction (as a crystallographic axis, such as 0,0,1 is supplied) -- note that for most crystal systems only one axis makes sense -- and two size parameters are defined, one for along the axis and one for in the perpendicular plane;

·      With ellipsoidal, six terms are used to define a broadening tensor that has arbitrary orientation -- this model may require constraints and is seldomly needed.

LGmix: Note that size broadening is usually Lorentzian, which corresponds to a LGmix value of 1.0; if this value is between 0. and 1., both Gaussian and Lorentz size broadening is modeled and a value of 0.0 is pure Gaussian. Values less than 0. or greater than 1. make no physical sense.

Microstrain peak broadening

is computed as unitless fraction of Δd/d (or equivalently ΔQ/Q) times 106. Microstrain can be computed in three ways: isotropic, uniaxial and generalized.

·      In isotropic broadening, microstrain broadening assumed to be the same in all crystallographic directions and a single value is supplied;

·      With uniaxial broadening, a preferred direction (as a crystallographic axis, such as 0,0,1) is supplied -- note that for most crystal systems only one axis makes sense -- and two microstrain parameters are defined, one for along the axis and one for in the perpendicular plane;

·      With generalized, the Nicolae Popa/Peter Stephens second-order expansion model is used and the number of terms will depend on the crystal system. It is typically possible to refine all terms when significant anisotropic strain broadening is present.

LGmix: Note that microstrain broadening is usually Lorentzian, which corresponds to a LGmix value of 1.0; if this value is between 0. and 1., both Gaussian and Lorentz broadening is modeled and a value of 0.0 is pure Gaussian. Values less than 0. or greater than 1. make no physical sense.

Hydrostatic/elastic strain

shifts the lattice constants for the contribution of a phase into a histogram. The values are added to the reciprocal lattice parameter tensor terms. They must be refined in sequential refinements or where the lattice constants are slightly different in different histograms (as an example see the Combined X-ray/CW-neutron refinement of PbSO4 tutorial.

Preferred orientation

is treated in one of two ways. Intensity corrections can be added to the model here or a full texture model is possible with the "Texture" tab (which usually requires multiple histograms at different sample or detector settings). The approaches available here are March-Dollase, which requires a definition of a unique axis (in crystallographic coordinates) and the relative amount of excess or depletion of crystallites in that direction; or Spherical Harmonics, where the selection of an order determines the shape of the probability surface (which is always constrained to match the symmetry of the crystal system).

Extinction

can occur when crystals/crystallites have minimal mosaic character, which results in lowering of diffraction intensities for the most intense reflections. This is not commonly seen in CW powder diffraction, but can be more apparent in neutron TOF data. For single crystal data the extinction model is more complex allowing for primary and two types of secondary extinction.

Disordered solvent – Babinet A & B

This correction, using the Babinet model, is typically used to treat scattering from solvent that is not well-ordered in protein structures. It probably makes no sense in most any other application.

Merohedral twins

Used for single crystal data; gives twin law transformation matrix and fraction for each twin member. These are for merohedral twins where the observed structure factors are a composite of contributions from each twin. Twin fractions are automatically constrained to sum to unity.

What can I do here?

1.     In this tab, menu items allow copying values or refinement flags to histograms/phases and selection of which histograms are used in the current phase.

2.     The plot selection items allow for three dimensional representations of the microstrain or crystallite size distributions (which are spheres for isotropic treatments); preferred orientation can be plotted as a Psi scan (a plot of relative crystallite abundance for a particular reflection as a function of azimuthal angle) or as an inverse pole figure (which shows in a stereographic projection the probability distribution for different reciprocal lattice directions for a particular sample orientation).

Atoms

This is the table of parameters for the atoms in this crystal structure model. The menu controls allow manipulation of the values, refinement flags as well as initiate calculations of geometrical values (distances & angles) among the atoms.

What can I do here?

1.     1. Atom selection from table - These are controlled by the mouse and the Shift/Ctrl/Alt keys. Note that for most purposes (one exception is atom reordering which requires an Alt-Left-click on the rows), selection of any cell for an atom will work equivalently with selection of the entire row. Upon selection the atoms will turn green in the structure drawing:

a.     Left Mouse Button (LMB) – on a row number selects the atom.

b.     Shift LMB – on a row number selects all atoms from last selection to the selected row (or top is none previously selected).

c.     Ctrl LMB – on a row number selects/deselects the atom.

d.     Alt LMB – on a row number selects that atom for moving; the status line at bottom of window will show name of atom selected. Use Alt LMB again to select a target row for this atom; insertion will be before this row and the table will be updated to show the change. NB: the Draw Atoms list is not updated by this change.

2.     Double left click a Type column heading: a dialog box is shown that allows you to select all atoms with that type.

3.     Double click a refine or I/A column heading: a dialog box will be shown with choices to be applied to every atom in the list.

4.     Atom data item editing tools – These are controlled by the mouse (Alt ignored, Shift & Ctrl allow selection of multiple cells but no use is made of them). An individual data item can be cut/pasted anywhere including from/to another document. Bad entries are rejected. If any entry is changed, press Enter key or select another atom entry to apply the change.

a.     Name – can change to any text string.

b.     Type – causes a popup display of the Periodic Table of the elements; select the element/valence desired; the atom will be renamed as well.

c.     refine – shows a pulldown of allowed refinement flag choices to be shown; select one (top entry is blank for no refinement).

d.     x,y,z – change atom coordinate. Fractions (e.g. 1/3, 1/4) are allowed.

e.     frac,Uiso,Uij – change these values; fractions (e.g. 1/3, 1/4) are allowed.

f.      I/A – select one of I(sotropic) or A(nisotropic); the Uiso/Uij entries will change appropriately.

5.     Menu ‘Edit Atoms’ - The edit menu shows operations that can be performed on your selected atoms. You must select one or more atoms before using many of the menu items.

a.     On selected atoms … -

1. Refine selected – A popup dialog box appears; select refinement flags to apply to all selected atoms.

2. Modify parameters – A popup dialog box appears with a list of atom parameter names; select one to apply to all selected atoms. Name will rename selected atoms according to position in table (e.g. Na(1) for Na atom as 1st atom in list in row ‘0’). Type will give periodic table popup; selected element valence will be used for all selected atoms and atoms names will be changed. I/A will give popup with choices to be used for all selected atoms. x,y,z will give popup for shift to be applied to the parameter for all selected atoms. Uiso and frac will give popup for new value to be used for all selected atoms.

3. Set viewpoint – Set the viewpoint to be position of 1st selected atom

4. Move atom to viewpoint – Move a single atom to viewpoint in plot.

5. Insert atom – insert an H atom (name= Unk) at 0,0,0 before the selected atom, it is also drawn as an H atom in the structure plot.

6. Insert viewpoint – insert an H atom (name= Unk) before the selected atom with coordinates matching the location of the viewpoint, it is also drawn as an H atom in the structure plot.

7. Calc H atoms – insert H-atoms in standard positions based on bonding patterns about selected atoms.

8. Delete atom – selected atoms will be deleted from the atom list; they should also vanish from the structure drawing.

9. Transform atoms – A popup dialog box appears; select space group operator/unit cell translation to apply to the selected atoms. You can optionally force the result to be within the unit cell and optionally generate a new set of atom positions. You may also invert a noncentrosymmetric structure. NB: many of these operations only make sense if all atoms are selected.

10.  Select all – Selects all atoms for further changes. Atoms in drawing will turn green.

11.  Select from list – A popup appears allowing selection of atoms for further changes. Selected atoms will turn green.

b.     Append atom – add an H atom (name= Unk) at 0,0,0 to the end of the atom table, it is also drawn as an H atom in the structure plot.

c.     Append viewpoint – add an H atom (name= Unk) to the end of the atom table with coordinates matching the location of the viewpoint, it is drawn as an H atom in the structure plot.

d.     Update H atoms

e.     Assemble molecule – move atoms to create single molecule; not appropriate for extended structures.

f.      Collect atoms – move atoms to be closest to selected position

g.     Reload draw atoms – reload drawing atoms from current atom list.

6.     Menu ‘Compute’ –

a.     Show Distances & Angles – compute distances and angles with esds (if possible) for selected atoms. A popup dialog box will appear with distance angle controls. NB: if atoms have been added or their type changed, you may need to do a Reset of this dialog box before proceeding.

b.     Save Distances & Angles – same as a. but reports result to a file with extension “.disagl”.

c.     Histogram bonds and angles – forms histograms of bond lengths & angles about selected atoms.

d.     Apportion atom frac – after selection of a 2nd element; this determines from atomic number and neutron scattering length the atom fractions of each type for selected atoms and presents results on the console.

e.     Density – calculate density

f.      ISODISTORT mode values -

What can I do with the plot?

A plot will be displayed only if the Draw Options or Draw Atoms tabs are visited before use of the Atoms tab. In that case the crystal structure is shown. Use of the mouse buttons changes the view of the structure and can be used to select atoms.

·  Left drag: Holding down left button rotates axes around screen x & y

·  Right drag: Holding down right button translates the fractional coordinates assigned to the viewpoint (which is kept at the center of the plot). The structure will appear to translate. The viewpoint can also be entered directly in the Draw Options.

·  Middle drag: Holding down center button rotates axes around screen z (direction perpendicular to screen).

·  Wheel: Rotating the scroll wheel: changes “camera distance” (zoom in/out)

·  Shift+Left click: Holding down the shift key while clicking on an atom with the left mouse button causes that atom to be selected (Shift + a Right click does the same). Any previously selected atoms will be reset. If two atoms are overlapped in the current view, then the top-most atom will usually be selected. Only atoms in the asymmetric unit can be selected from the plot in this way.

·  Shift+Right click: Holding down the shift key while clicking on an atom with the right mouse button causes the atom to be selected if previously unselected and unselected if previously selected. Any previously selected atoms will be continue to be selected so shift-right click can be used to add atoms to the selection list. If two atoms are overlapped in the current view, then the top-most atom will usually be selected. Only atoms in the asymmetric unit can be selected from the plot in this way.

·      Key ‘n’: Select next atom in the displayed atom list.

·      Key ‘p’: Select the previous atom in the displayed atom list.

·      Key ‘c’: Set viewpoint at unit cell center. Resets n/p selection item to 1st atom.

 

Draw Options

What can I do here?

The Draw Options window provides access to a number of items that control how the structure is displayed.

What is plotted here?

A plot that shows the atoms of the crystal structure is generated. The atoms are displayed according to the controls in the in this page as well as options on the Draw Atoms page.

What can I do with the plot?

Use of the mouse buttons when viewing a crystal structure changes the view of the structure:

·  Holding down left button (left drag): rotates axes around screen x & y

·  Holding down right button (right drag): translates the fractional coordinates assigned to the view point (which is kept at the center of the plot). Note that the view point coordinates can also be entered directly.

·  Holding down center button (center drag): rotates axes around screen z

·  Rotating the scroll wheel: changes “camera position” (zoom in/out)

Draw Atoms

This gives a list of the atoms and bonds that are to be rendered as lines, van der Waals radii balls, sticks, balls & sticks, ellipsoids & sticks or polyhedra. There are two menus for this tab; Edit allows modification of the list of atoms to be rendered and Compute gives some options for geometric characterization of selected atoms.

What can I do here?

1.     Atom Selection from table: select individual atoms by a left click of the mouse when pointed at the left most column (atom numbers) of the atom display; hold down the Ctrl key to add to your selection; a previously selected atom will be deselected; hold down Shift key to select from last in list selected to current selection. A selected atom will be highlighted (in grey) and the atoms will be shown in green on the plot. Selection without the Ctrl key will clear previous selections. A double left click in the (empty) upper left box will select or deselect all atoms.

2.     Atom Selection from plot: select an atom by a left click of the mouse while holding down the Shift key and pointed at the center of the displayed atom, it will turn green if successful and the corresponding entry in the table will be highlighted (in grey); any previous selections will be cleared. To add to .your selection use the right mouse button (Shift down); if a previously selection is reselected it is removed from the selection list. NB: beware of atoms that are hiding behind the one you are trying to select, they may be selected inadvertently. You can rotate the structure anytime during the selection process.

3.     Double left click a Name, Type and Sym Op column heading: a dialog box is shown that allows you to select all atoms with that characteristic. For example, selecting the Type column will show all the atom types; your choice will then cause all those atoms to be selected.

4.     Double left click a Style, Label or Color column: a dialog box is shown that allows you to select a rendering option for all the atoms. For Color a color choice dialog is displayed that covers the entire color spectrum. Choose a color by any of the means available, press the “Add to Custom Colors”, select that color in the Custom colors display and then press OK. NB: selecting Color will make all atoms have the same color and for Style “blank” means the atoms aren’t rendered and thus the plot will not show any atoms or bonds!

5.     Menu ‘Edit’ - The edit menu shows operations that can be performed on your selected atoms. You must select one or more atoms before using any of the menu items. Most of these items can also be accessed by selecting one or more atoms and right-clicking the mouse.

a.     Atom style – select the rendering style for the selected atoms

b.     Atom label – select the item to be shown as a label for each atom in selection. The choices are: none, type, name or number.

c.     Atom color – select the color for the atom; a color choice dialog is displayed that covers the entire color spectrum. Choose a color by any of the means available, press the “Add to Custom Colors”, select that color in the Custom colors display and then press OK.

d.     Reset atom colors – return the atom color back to their defaults for the selected atoms.

e.     Edit atom radii -

f.      View point – position the plot view point to the first atom in the selection.

g.     Select from list -

h.     Add atoms – using the selected atoms, new ones are added to the bottom of the list after applying your choice of symmetry operator and unit cell translation selected via a dialog display. Duplicate atom positions are not retained. Any anisotropic thermal displacement parameters (Uij) will be transformed as appropriate.

i.      Add sphere of atoms -

j.      Transform draw atoms – apply a symmetry operator and unit cell translation to the set of selected atoms; they will be changed in place. Any anisotropic thermal displacement parameters (Uij) will be transformed as appropriate.

k.     Fill CN-sphere – using the atoms currently in the draw atom table, find all atoms that belong in the coordination sphere around the selected atoms via unit cell translations. NB: symmetry operations are not used in this search.

l.      Fill unit cell - using the atoms currently selected from the draw atom table, find all atoms that fall inside or on the edge/surface/corners of the unit cell. This operation is frequently performed before Fill CN-sphere.

m.   Complete molecule

n.     Create void map -

o.     Delete atoms – clear the entire draw atom table; it is then refilled from the Atoms table. You should do this operation after any changes in the Atoms table, e.g. by a structure refinement.

p.     Update draw atoms

q.     Load selected atoms -

6.     Menu ‘Compute’ - The compute menu gives a choice of geometric calculations to be performed with the selected atoms. You must select the appropriate number of atoms for these to work and the computation is done for the atoms in selection order.

a.     View pt. dist. - this calculates distance from view point to all selected draw atoms; result is given on the console window.

b.     Dist. Ang. Tors. – when 2-4 atoms are selected, a distance, angle or torsion angle will be found for them. The angles are computed for the atoms in their selection order. The torsion angle is a right hand angle about the A2-A3 vector for the sequence of atoms A1-A2-A3-A4. An estimated standard deviation is given for the calculated value if a current variance-covariance matrix is available. The result is shown on the console window; it may be cut & pasted to another application (e.g. Microsoft Word).

c.     Best plane – when 4 or more atoms are selected, a best plane is determined for them. The result is shown on the console window; it may be cut & pasted to another application (e.g. Microsoft Word). Shown are the atom coordinates transformed to Cartesian best plane coordinates where the largest range is over the X-axis and the smallest is over the Z-axis with the origin at the unweighted center of the selection. Root mean square displacements along each axis for the best plane are also listed. The Z-axis RMS value indicates the flatness of the proposed plane. NB: if you select (e.g. all) atoms then Best plane will give Cartesian coordinates for these atoms with respect to a coordinate system where the X-axis is along the longest axis of the atom grouping and the Z-axis is along the shortest distance. The origin is at the unweighted center of the selected atoms.

What is plotted here?

A plot that shows the atoms of the crystal structure is generated. The atoms are displayed according to the controls in the in this page as well as options on the Draw Options page.

What can I do with the plot?

Use of the mouse buttons when viewing a crystal structure changes the view of the structure:

·  Left drag: Holding down left button rotates axes around screen x & y

·  Right drag: Holding down right button translates the fractional coordinates assigned to the view point (which is kept at the center of the plot). The structure will appear to translate. (On Mac control+mouse drag will also do this). The view point can also be entered directly in the Draw Options.

·  Middle drag: Holding down center button rotates axes around screen z (direction perpendicular to screen).

·  Mouse Wheel: Rotating the scroll wheel: changes “camera position” (zoom in/out)

·  Shift+Left click: Holding down the shift key while clicking on an atom with the left mouse button causes that atom to be selected. Any previously selected atoms will be reset. If two atoms are overlapped in the current view, then the top-most atom will usually be selected. Atom selection requires that either the "Atoms" or "Draw Atoms" phase be displayed.

·  Shift+Right click: Holding down the shift key while clicking on an atom with the right mouse button causes the atom to be selected if previously unselected and unselected if previously selected. Any previously selected atoms will be continue to be selected so shift-right click can be used to add atoms to the selection list. (On Mac control+mouse click will also do this). If two atoms are overlapped in the current view, then the top-most atom will usually be selected. Atom selection requires that either the "Atoms" or "Draw Atoms" phase be displayed.

RB Models

This is used to insert rigid bodies into a structure. The rigid bodies must first be defined for the project using the Rigid bodies tree item. It also allows control of the location of the rigid body and in this phase

What can I do with the plot?

Use of the mouse buttons when viewing a crystal structure changes the view of the structure:

·  Holding down left button (left drag): rotates axes around screen x & y

·  Holding down right button (right drag): translates the fractional coordinates assigned to the view point (which is kept at the center of the plot). The structure will appear to translate. The view point can also be entered directly in the Draw Options.

·  Holding down center button (center drag): rotates axes around screen z

·  Rotating the scroll wheel: changes “camera position” (zoom in/out)

When a rigid body is being inserted into a structure, both the rigid body and the crystal structure are displayed. It is useful to plan for this by preselecting the atoms in the Draw Atoms list and to have atoms displayed as "Sticks" or "Ball-and-Sticks." The rigid body will be displayed as "Ball-and-Sticks" but bonds will be in green. Use of the Alt key causes the above mouse movements to reposition the rigid body rather than change the view of the crystal structure:

·  Alt+Left drag: Holding Alt while dragging the mouse with the left button down rotates the rigid body around screen x & y axes

·  Alt+Middle drag: Holding Alt while dragging the mouse with the middle button down rotates the rigid body around screen z axis (out of screen)

·  Alt+Right drag: Holding Alt while dragging the mouse with the right button down translates the rigid body in the screen x & y directions (rotate the plot to see and move in the rigid body in the third direction.) Pressing the "Lock" checkbox next to the origin location prevents the origin from being changed in this way.

Texture

 

This tab is used to control settings used for a texture study of a material. This type of characterization requires diffraction data recorded with multiple detector orientations (the number of orientations will depend on sample and material symmetry). Do not confuse this with applying a preferred orientation correction (found in the "Data" tab) in a structural study. The sample orientation relative to the detector axes is specified here and the detector orientation is specified for each histogram as goniometer omega, chi, phi and azimuth values (details below). These values must be specified.

 

Texture analysis using GSAS-II employs spherical harmonics modeling, as described by Bunge, "Texture Analysis in Materials Science" (1982), and implemented by Von Dreele, J. Appl. Cryst., 30, 517-525 (1997) in GSAS. The even part of the orientation distribution function (ODF) via the general axis equation

is used to give the intensity corrections due to texture. The two harmonic terms,  and , take on values according to the sample and crystal symmetries, respectively, and thus the two inner summations are over only the resulting unique, nonzero harmonic terms. These unique terms are automatically selected by GSAS-II according to the space group symmetry and the user chosen sample symmetry. The available sample symmetries are cylindrical, 2/m, mmm and no symmetry. The choice of sample symmetry profoundly affects the selection of harmonic coefficients. For example, in the case of cylindrical sample symmetry (fiber texture) only kL0(y) terms are nonzero so the rest are excluded from the summations and the set of CL0n coefficients is sufficient to describe the effect on the diffraction pattern due to texture. The crystal harmonic factor, , is defined for each reflection, h, via polar and azimuthal coordinates (f, b) of a unit vector coincident with h relative to the reciprocal lattice. For most crystal symmetries, f is the angle between h and the n-th order major rotation axis of the space group (usually the c-axis) and b is the angle between the projections of h and any secondary axis (usually the a-axis) onto the normal plane.  In a similar way the sample harmonic factor, , is defined according to polar and azimuthal coordinates (y, g) of a unit vector coincident with the diffraction vector relative to a coordinate system attached to the external form of the sample. For example, in the case of a rolled steel plate having mmm symmetry, the polar angle, y, is frequently measured from the normal direction (ND, parallel to Ks) and g is then measured from the rolling direction (RD, parallel to Is) in the TD (transverse direction, parallel to Js) - RD plane.  Thus, the general axis equation becomes


Note that this version of the general axis equation differs from that shown in Von Dreele (1997) in that the assignment of m and n are reversed.

In a diffraction experiment the crystal reflection coordinates (f, b) are determined by the choice of reflection index (hkl) while the sample coordinates (y, g) are determined by the sample orientation on the diffractometer. To define the sample coordinates (y, g), we have defined an instrument coordinate system (I, J, K) such that K is normal to the diffraction plane and J is coincident with the direction of the incident radiation beam toward the source. We further define a standard set of right-handed eulerian goniometer angles (W, C, F) so that W and F are rotations about K and C is a rotation about J when W  = 0.  Finally, as the sample may be mounted so that the sample coordinate system (Is, Js, Ks) does not coincide with the instrument coordinate system (I, J, K), we define three eulerian sample rotation offset angles (Ws, Cs, Fs) that describe the rotation from (Is, Js, Ks) to (I, J, K).  The sample rotation angles are defined so that with the goniometer angles at zero Ws and Fs are rotations about K and Cs is a rotation about J.  The zeros of these three sample rotation angles can be refined as part of the Rietveld analysis to accommodate any angular offset in sample mounting. For the specific case of cylindrical sample symmetry, the cylinder axis is coincident with Ks as is the 2-fold in 2/m sample symmetry. After including the diffraction angle, Q, and a detector azimuthal angle, A, the full rotation matrix, M, is

M = -QAWC(F+Fs)CsWs

By transformation of unit Cartesian vectors (100, 010 and 001) with this rotation matrix, the sample orientation coordinates (y, g) are given by

cos(y) =  and   tan(g) =

The harmonic terms,  and , are developed from (those for  are similar)

where the normalized associated Legendre functions, , are defined via a Fourier expansion as

for n even and

for n odd.  Each sum is only over either the even or odd values of s, respectively, because of the properties of the Fourier coefficients, .  These Fourier coefficients are determined so that the definition

is satisfied.  Terms of the form  and  are combined depending on the symmetry and the value of n (or m) along with appropriate normalization coefficients to give the harmonic terms  and .  For cubic crystal symmetry, the term  is obtained directly from the Fourier expansion

using the coefficients, , as tabulated by Bunge (1982).

The Rietveld refinement of texture then proceeds by constructing derivatives of the profile intensities with respect to the allowed harmonic coefficients, , and the three sample orientation angles, Ws, Cs, Fs, all of which can be adjustable parameters of the refinement. Once the refinement is complete, pole figures for any reflection may be constructed by use of the general axis equation, the refined values for  and the sample orientation angles Ws, Cs, Fs.

The magnitude of the texture is evaluated from the texture index by

If the texture is random then J = 1, otherwise J > 1; for a single crystal J = ¥.

In GSAS-II the texture is defined in two ways to accommodate the two possible uses of this correction. In one, a suite of spherical harmonics coefficients is defined for the texture of a phase in the sample; this can have any of the possible sample symmetries and is the usual result desired for texture analysis. The other is the suite of spherical harmonics terms for cylindrical sample symmetry for each phase in each powder pattern (“histogram”) and is usually used to accommodate preferred orientation effects in a Rietveld refinement. The former description allows refinement of the sample orientation zeros, Ws, Cs, Fs, but the latter description does not (they are assumed to be zero and not refinable). The sample orientation angles, (W, C, F) are specified in the Sample Parameters table in the GSAS-II data tree structure and are applied for either description.

Some useful examples:

1) Bragg-Brentano laboratory powder diffractometer

The conventional arrangement of this experiment is to have a flat sample with incident and diffracted beams at equal angles (theta) on opposite sides of the sample. The sample is frequently spun about its normal to improve powder statistics and impose cylindrical symmetry on any preferred orientation (texture). Thus, the diffraction plane (source, diffraction vector & detector) contains the K-vector which is parallel to the diffraction vector and W, C, F = 0.

2) Debye-Scherrer diffractometer with point detector(s)

The usual arrangement here is to have a capillary sample perpendicular to the diffraction plane. The capillary may be spun about its cylinder axis for powder averaging and to impose cylindrical symmetry on the texture which is perpendicular to the diffraction plane. Thus, W, F = 0 and C =90.

3) Debye-Scherrer diffractometer with 2D area detector

The area detector is presumed to be directly behind the sample with the incident beam somewhere near the center of the detector. The detector axes are defined (for a synchrotron) with the X-axis toward the synchrotron ring and the Y-axis vertical “up”; one views the detector image as if looking from the x-ray source. The sample is assumed to be a capillary (which may be spun to impose cylindrical symmetry), although other sample shapes may be used, and is aligned with the cylinder axis horizontal. Integration of the image from a series of “caked” slices gives a set of powder patterns, each assigned an azimuthal angle where zero is along the X-axis. Thus, at azimuth=0 the diffraction plane is horizontal and contains the cylinder axis so W, C, F = 0.

What can I do here?

1. Menu ‘Texture/Refine texture’ – refines the spherical harmonics texture model using the predetermined values of Prfo for all histogram reflection sets as demonstrated in 2DTexture tutorial.

 

2. Texture settings:

 

The texture index, J is shown on the 1st line. The Texture model can be chosen from [‘cylindrical’, ’none’, ‘shear - 2/m’, or ‘rolling – mmm’].

 

The Harmonic order (even integer 0-34), refine flag & show coefficients flag are next.

 

The Texture plot type is one of:

·       as an "Axial pole distribution" which simulates the intensity of a reflection during a phi scan.

·       as a "pole figure," where a projection of the probability of finding a pole (hkl) is plotted as a function of sample orientation.

·       as a "inverse pole figure," where a projection of the probability of finding all poles (hkls) is plotted for a selected sample orientation.

·       or as a "3D pole distribution" that shows the probability of finding a pole (hkl) is plotted as a function of sample orientation.

For Axial distribution, pole figure and 3D pole distribution one must next select the hkl of the desired pole, for Inverse pole figure one must select a sample direction (typically 0 0 1).

One can choose the contour (pole & inverse pole figures) color scheme (default “Paired”) and make a CSV file of the image for import into other software.

The spherical harmonics coefficients are shown next; they may be edited. They may be cleared by setting harmonic order to zero and then back to desired value.

Lastly, the sample orientation angle zeros (Ws, Cs, Fs) are shown with their individual refinement flags.

Map peaks

This gives the list (magnitude, x y & z) of all peaks found within the unit cell from the last Fourier/charge flip map search sorted in order of decreasing peak magnitude. The crystal structure plot shows each peak position as a white to dark gray cross; the shade is determined from the magnitude for the peak relative to the maximum peak magnitude. Negative peaks shown in orange.

What can I do here?

1.     Peak Selection from table: select individual atoms by a left click of the mouse when pointed at the left most column (atom numbers) of the atom display; hold down the Ctrl key to add to your selection; a previously selected atom will be deselected; hold down Shift key to select from last in list selected to current selection. A selected atom will be highlighted (in grey) and the atoms will be shown in green on the plot. Selection without the Ctrl key will clear previous selections. A left click in the (empty) upper left box will select or deselect all atoms.

2.     Select the mag column – the entries will be sorted with the largest at the top.

3.     Select the dzero column – the entries will be sorted with the smallest (distance from origin) at the top.

4.     Select the dcent column – the entries will be sorted with the smallest distance from the unit cell center at the top.

5.     Menu ‘Map peaks 

a.     Move peaks – this copies selected peaks to the Atoms list and the Draw Atoms list. They will be appended to the end of each list each with the name ‘UNK’ and the atom type as ‘H’. They will also be drawn as small white spheres at their respective positions in the structure drawing. You should next go to the Atoms page and change the atom type to whatever element you desire; it will be renamed automatically.

b.     View point – this positions the view point (large 3D RGB cross) at the 1st selected peak.

c.     View pt. dist. – this calculates distance from view point to all selected map peaks.

d.     Hide/Show bonds – toggle display of lines (bonds) between peaks

e.     Calc dist/ang – if 2 peaks are selected, this calculates the distance between them. If 3 peaks are selected this calculates the angle between them; NB: selection order matters. If selection is not 2 or 3 peaks this is ignored. Output is on the console window.

f.      Equivalent peaks – this selects all peaks related to selection by space group symmetry.

g.     Invert peak positions – inversion through cell center of map and all positions.

h.     Roll charge flip map – popup allows shifting of the map & all peak positions by unit cell fractions; can be along combinations of axes.

i.      Unique peaks – this selects only the unique peak positions amongst those selected; a popup allows selection of atom subset closest to x=0, y=0, z=0 origin or center.

j.      Save peaks – saves the peak list as a csv file.

k.     Delete peaks – this deletes selected peaks. The shading on the remaining peaks is changed to reflect any change in the maximum after deletion.

l.      Clear peaks – this deletes all the peaks in the map peak list; they are also removed from the crystal structure drawing plot.

Pawley reflections

This gives the list of reflections used in a Pawley refinement and they can only be seen if the ‘Do Pawley refinement’ flag is set (see General).

What can I do here?

1.     Menu ‘Operations’

a.     Pawley settings – allows setting of Pawley parameters as shown on the General tab.

b.     Pawley create – this creates a new set of Pawley reflections, over writing any preexisting Pawley set. They are generated with d-spacings larger than the limit set as ‘Pawley dmin’ in the General tab for this phase. By default the refine flags are not set and the Fsq(hkl) = 100.0.

c.     Pawley estimate – this attempts an estimate of Fsq(hkl) from the peak heights of the reflection as seen in the 1st powder pattern of those selected in the Data tab.

d.     Pawley update – process Pawley reflection set for negative intensities. These are set to ½ its absolute value for noncentrosymmetric space groups (0.3 otherwise); the refine flag is turned off. One should repeat Pawley refinement and then do Refine all and an additional refinement. Repeat as needed to remove negative intensities. Set Pawley neg. wt. (see Pawley settings) to further suppress negatives.

e.     Refine all – sets all refine flags

f.      Refine none – clears all refine flags

g.     Toggle selection – toggles all refine flags

2.     You can change the refine flags either by clicking on the box or by selecting one and then selecting the column (a single click on the column heading). Then type ‘y’ to set the refine flags or ‘n’ to clear the flags. You should not refine those reflections that fall below the lower limit or above the upper limit of the powder pattern otherwise you may have a singular matrix error in your Pawley refinement.

3.     You can delete an individual reflection from the Pawley set by selecting its row (will be highlighted) and then pressing the Delete key (this is not reversable & only deletes the 1st one selected).

4.     You can change the individual Fsq(hkl) values by selecting it, typing in the new value and then pressing enter or selecting somewhere else in the table.

Layers

            This is used to set up stacking fault models for simulations of x-ray diffraction patterns. See for example the Stacking Faults-I tutorial. The computations are done by a modified version of DIFFaX by  M.M.J. Treacy, J.M. Newsam and M.W. Deem, Proc. Roy. Soc. Lond. 433A, 499-520 (1991)

What can I do here?

1.     Menu ‘Operations’

a. Load from DIFFaX file – load parameters from a DIFFaX input file

b. Copy phase cell – copy the lattice parameters from a selected phase (usually transformed from average unit cell)

c. Simulate pattern – run DIFFaX to simulate selected pattern

d. Fit pattern – refine stacking fult parameters to fit observed pattern (not available yet)

e. Sequence simulations – do a sequence of simulations incrementing a selected stacking fault parameter

2.     Show a plot of the 2D diffraction pattern for the stacking model – look for streaks.

3.     Select Laue symmetry

4.     Reference unit cell – filled by Copy phase cell and is the stacking fault block dimensions (NB: refine inactive)

5.     Layer width (a & b) – outer dimensions of crystallite; used for broadening calculations (NB: refine inactive)

6.     Next are descriptions of the layers to be used in the calculations. They can be created atom-by-atom or imported from another GSAS-II gpx file. If a layer is already present, then the new layer can be the same; give it a different name.

7.     The layers stack according to probability rules – these are presented in tables in the next section

8.     You can specify specific layering sequences as a sequence of layer numbers (begins with 1).

9.     Finally, you can set the type of sequence and the number of layers to use in the simulation

 

You can draw the layer structures as well as sequences of layers to check on how they fit together; see Plot boxes for this.

Wave Data

What can I do here?

MC/SA

What can I do here?


Last modified: Sat Jun 19 21:43:10 CDT 2021