Changes between Version 4 and Version 5 of InstallOSX


Ignore:
Timestamp:
Mar 12, 2010 5:36:33 PM (11 years ago)
Author:
toby
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • InstallOSX

    v4 v5  
    33This page describes a new method for installing GSAS & EXPGUI where a small disk image is downloaded, which  contains a script that loads the latest versions of GSAS and EXPGUI. When GSAS & EXPGUI are loaded in this fashion, a menu item is activated in EXPGUI that allows it to check for updates and install them. At present, this is only possible on Macs with Intel processors.
    44
    5 The software installation is done using a program called subversion (svn), in addition the installation script is run using the Python interpreter. Subversion comes preloaded on Leopard (10.5) and Snow Leopard systems (10.6), but Fink or some other approach must be used to load subversion for 10.4. I believe that python can be found on all of these OS versions.
     5The software installation is done using a program called subversion (svn), in addition the installation script is run using the Python interpreter. I believe that python can be found on OS X in the default installation from 10.4 on. Subversion comes preloaded on Leopard (10.5) and Snow Leopard systems (10.6). '''Users of 10.4 (Tiger) will need to install subversion''' this can be done with [http://www.finkproject.org/ Fink], [http://darwinports.com/ DarwinPorts] or [http://www.macports.org/ MacPorts]. Note that all that is needed is the svn client, should you have a choice in package size.
    66
    7 Here is the procedure needed to load GSAS & EXPGUI using this method:
     7== How to install GSAS & EXPGUI ==
     8
     9Here is the procedure needed to load GSAS & EXPGUI:
    810
    911 * Download file http://11bm.xor.aps.anl.gov/downloads/gsas/svnload/gsassvn_i86.dmg
     
    2123EXPGUI is started by clicking on the expgui icon, or by dragging .EXP files or directories onto the expgui icon. On occasion, nothing happens when I click on the icon. Closing or restarting X11 seems to fix this problem.
    2224
     25== Upgrades ==
     26
     27In EXPGUI, one can press the "Upgrade GSAS/EXPGUI" menu button in the File menu. The response to this will be a window that says if there are updates to download or that the programs are "up-to-date". If there are updates, you have the option of installing them and restarting EXPGUI.
     28
     29If you do not use EXPGUI, you can update by clicking on the bootstrap.py in the gsas folder.
     30
     31Note that if you make any modifications to any files distributed as part of GSAS or EXPGUI, these files may not be upgraded, should the changes be in the same regions as upgrades made by Bob or myself. If you are in the practice of modifying the programs, you should learn to use svn and do your upgrades by hand.
     32