Changes between Version 9 and Version 10 of InstallLinux


Ignore:
Timestamp:
Apr 16, 2010 10:47:54 PM (11 years ago)
Author:
toby
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • InstallLinux

    v9 v10  
    11= Installing GSAS & EXPGUI on Linux =
    22
    3 There are two ways provided here to install GSAS & EXPGUI. The first is preferred since is downloads directly from a subversion repository. In this method the distribution .tar file does not need to change when the program is updated. Instead, the latest version of the programs are downloaded from a server when the program is installed (an internet connection is obviously required). Subsequently, if there are updates to GSAS or EXPGUI, an update can be made where only the modified or added files are upgraded. This update step can be done using the File/Update... menu option in EXPGUI or by executing the bootstrap.py file in the GSAS directory. However, these methods require ~double the space needed by GSAS & EXPGUI. For users who need to install GSAS & EXPGUI on systems where an Internet connection to the server is not possible or where space usage is critical, an alternate .tar file is also provided containing all GSAS & EXPGUI files, but this requires that upgrades be performed by downloading and installing the all GSAS & EXPGUI files from a future distribution.
     3There are two ways provided here to install GSAS & EXPGUI. The first is preferred since it downloads directly from a subversion repository. In this method the distribution .tar file does not need to change when the program is updated. Instead, the latest version of the programs are downloaded from a server when the program is installed (an internet connection is obviously required). Subsequently, if there are updates to GSAS or EXPGUI, an update can be made where only the modified or added files are upgraded. This update step can be done using the File/Update... menu option in EXPGUI or by executing the bootstrap.py file in the GSAS directory. However, these methods require ~double the space needed by GSAS & EXPGUI. For users who need to install GSAS & EXPGUI on systems where an Internet connection to the server is not possible or where space usage is critical, an alternate .tar file is also provided containing all GSAS & EXPGUI files, but this requires that upgrades be performed by downloading and installing the all GSAS & EXPGUI files from a future distribution.
    44
    55There are so many flavors and releases of Linux in use, it is hard to prepare a installer that works on all platforms. Some testing has been done with Fedora Core 10 & 12. Please send feedback on experience with other systems to mailto:toby@anl.gov
     
    1717    * Fedora core 12: the initial yum-loaded version of BLT failed. Be sure to upgrade to blt.i686 (2.4-'''32'''.z.fc12 or later); the `.../gsas/exe/ncnrpack` also image works fine on FC12, but has less attractive fonts.
    1818
    19  * '''GSAS''': The GSAS image files (in .../gsas/exe) are compiled using g77, which will require a compatibility library to run on many modern Linux versions.
     19 * '''GSAS''': The GSAS image files (in .../gsas/exe) are compiled using g77, which will require a compatibility library to run on many modern Linux versions. If you have problems
     20Here are some of the packages that need to be installed to have these files run:
     21    * FC10: libgcc, glibc, libxcb, libX11, libXau, libXdmcp
     22    * FC12: libgcc, glibc, libxcb, libX11, libXau
    2023
    2124== Self-Upgrading GSAS & EXPGUI Installation Commands ==
     
    4952There are many other ways, using GUI tools, to accomplish the same tasks. The gist is to download http://11bm.xor.aps.anl.gov/downloads/gsas/svnload/gsassvnlinux.tar.gz and expand that into the location where GSAS and EXPGUI will be installed.
    5053
    51 You are on your own to create shortcuts.
     54With this download method, you are on your own to create shortcuts.