EXPGUI top Next page
(Utilities)
Previous page


EXPGUI, Menu Contents

C. Menu Contents

Note that the figures on this page are likely to be out of date with respect to the text. The text is updated more frequently. Also, note that not all menu options are available in Windows.

C.1 File Menu

The options on the File menu as is the custom contains the commands for reading and writing experiment files, as well as starting and ending the program.
Open
Select an existing GSAS experiment to be used. If a name is entered that does not exists, it is possible to create a new experiment file from scratch.
expnam
Equivalent to Open (included for historical reasons.)
Save
Saves modifications to the current experiment file to disk (shortcut Alt-S).
Save As
Saves modifications to the current experiment file to disk under a new file name
Reread .EXP file
Reread the last saved version of the experiment file from disk.
Update GSAS/EXPGUI
This queries the EXPGUI software repository to see if any files in EXPGUI or GSAS has been updated. It then offers the program user the option to update these files. The update will fail if the user does not have permission to change the EXPGUI or GSAS files. In this case, a system administrator may be needed.
revert
Used to load an archived (backup) version of the current .EXP file.
EraseHistory
Deletes old history records to speed reading of the .EXP file.
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse) -- this is not likely to be needed, as GSAS now does most conversions automatically.
exit
Exit EXPGUI (shortcut Alt-X or ^C)
EXPGUI Screen snapshot

C.2 Options Menu

This menu contains options that determine how EXPGUI runs.
archive EXP
Toggles archiving of .EXP files. When on, files are saved before they are overwritten by EXPGUI as a file named EXPNAM.Oxx where xx is a pair of hexidecimal digits (01, 02,..., 09, 0A,... OF, 10,... FF). Each time that EXPGUI archives a file, note is placed in the .LST file so that the saved file name can be associated with the refinement stage. Turning this option off, prevents EXPGUI from creating these EXPNAM.Oxx archive files, but the will still be created by EXPEDT, GENLES,...

Use DISAGL Window
When this option is set, results from DISAGL are shown in a separate window. When it is not set, the results are written in the .LST file. Note that on Windows, LSTVIEW can interfere with putting output into the DISAGL window. The solution is to close LSTVIEW before running DISAGL.
Autoload EXP
Normally EXPGUI prompts before rereading the EXP file when GENLES, POWPREF,... or other GSAS programs run If this option is set, the new file is automatically read without a prompt. The advantage of leaving this option off, is that you can opt to not load the revised .EXP file, which means that you reject the last set of changes. This is useful if GENLES blows up or you have done something wrong. The reason to turning "autoload EXP" on is that there is one less thing to do when running GSAS programs. Note that it is still possible to reverse changes, if archive files, but this may require more effort. See the File/revert menu entry.
Prompt after GSAS run
New! By default, GSAS programs are run in a separate window and after the program completes, the window remains open until enter is pressed in the window. Turning the "Prompt after GSAS run" option off, causes the window to be closed immediately after the program completes, saving some effort but obliterating any error messages or other evidence of problems.
Iconify during GSAS
If this option is turned on, the main EXPGUI window is shrunk to an icon (minimized) while GSAS programs are running and EXPGUI is suspended. The author prefers this mode, since there is no reason to have the screen cluttered with EXPGUI when it can't be used, but this is an option so that the mode can be turned off by those people who find this behavior annoying. It appears this option causes problems on Windows 7.
Autostart GRWND
This option is available on Windows-95, -98 and -ME to deal with a operating system quirk that prevents the starting of the GRWND.EXE program, needed for graphics in GSAS programs such as POWPLOT, RAWPLOT, EXPEDT,... (this program is not needed for EXPGUI graphics, such as LIVEPLOT). It is not understood why this error happens or how to prevent it. One cure is to start this GRWND.EXE program before starting the GSAS program. If this option is selected, each time a GSAS program is started, a separate program TLIST.EXE is used to check if GRWND.EXE is running. If it is not, EXPGUI will start this program before starting the requested GSAS program.
Sort atoms by
Determines the order that atoms are displayed on the "Phase" pane Atoms may be displayed sorted by number, atom type, site multiplity, occupancy, or by x, y or z coordinate

Clicking on the heading above the atoms list cycles with the left mouse button cycles through the atom sort modes. Clicking with the right mouse button resets the atom sort mode to "number".

Sort histograms by
Determines the order that histograms are displayed on the Histogram, Scaling and Profile panes Histograms may be sorted by histogram number, histogram type, original bank number, or diffraction angle/wavelength
Multiple hist. selection
When this mode is off, it is possible to modify parameters and refinement flags for only a single histogram. For other settings, it is possible to modify parameters and flags for groups of histograms (see help for Mouse actions). It does not make sense, however, to globally modify instrument-related parameters and flags for different histogram types. So global actions can be limited to a single class of histogram types (e.g. TOF, CW Neutron,...), which allows these parameters to be set for groups of similar histograms. Thus, if this mode is set to "All" the Histogram and Profile panes are disabled.
Override backspace
This option is available in UNIX only, as there are different ways that backspace can be implemented. When option is set as "On," the backspace key is overridden to send a "delete" character. If backspace does not work in a program such as EXPEDT, change try the other setting for this option.
Set Screen Font
This menu changes the fonts used in most sections of EXPGUI. Note that this setting can be saved with the SaveOptions menu option (below) so that EXPGUI automatically starts with the chosen font.
Show EXPTOOL output
Normally EXPGUI does not show the output from EXPTOOL, when actions like adding atoms, phases or histograms is performed. If an error is detected, the output is shown. If there are problems with adding phases, atoms, histograms... and a window showing an error does not appear, this option should be set to "on" so the output from EXPTOOL is always shown.
Save Options
Save the current values for "Override backspace", "Sort atoms by", "Sort histograms by", "archive EXP", "Autoload EXP", "Set Screen Font", and "Iconify during GSAS" in file ~/.gsas_config (or c:\gsas.config on Windows).
Save Position
Saves the current screen position of the EXPGUI window as the starting point for future runs of EXPGUI in in file ~/.gsas_config (or c:\gsas.config on Windows).
liveplot_options
Used to set options for LIVEPLOT, for example, the histogram to be plotted
Assign app to .EXP files
(on Mac only) When selected, this causes .EXP files to be linked (via the file resource fork) to the EXPGUI applescript. This also causes the .EXP files to be displayed with a GSAS icon.
EXPGUI Screen snapshot

C.3 Powder Menu

This menu contains links to GSAS programs used for powder diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
powpref
Powder data preparation (shortcut Alt-P)
genles
Run GSAS experiment editor (shortcut Alt-G)
powplot
Display powder patterns
rawplot
Plot powder data
fitspec
Fit a TOF vanadium scattering spectrum
bkgedit
Invokes the BKGEDIT program to fit a background function to a set of fixed background points.
excledt
Invokes the EXCLEDT program to set the upper and lower limits for a histogram, as well as edit excluded regions.
seqgsas
Invokes the sequential GSAS refinement program to run GENLES on a set of very similar data files.
mustrplot
Plot microstrain results
instedit
Invokes the instedit to edit an instrument parameter file.
New InstParm file
Creates a new instrument parameter file using instedit.
EXPGUI Screen snapshot

C.4 Xtal (Single Crystal) Menu

This menu contains links to GSAS programs used for single-rystal diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
genles
Run GSAS experiment editor (shortcut Alt-G)
scabs
Single crystal absorption
scmerge
Sort and merge single crystal data
sxtldata
Prepare generic single crystal data
EXPGUI Screen snapshot

C.5 Graphics Menu

This menu contains links to several GSAS and two non-GSAS (LIVEPLOT, and widplt) programs used for graphical display of data and results.
Fourier
Provides an interface to set up computation of Fourier maps and compute them using program Fourier. Also see the Export to DRAWxtl interface, which can be used to set up, compute, export and display Fourier maps. Note that a Fourier map can be set up for only one phase at a time.
forsrh
Search Fourier map for peaks
forplot
Display Fourier maps (set Fourier options in EXPEDT and then compute with FOURIER
polfplot
Display polefigures
powplot
Display powder patterns
ortep
Draw crystal structure
rawplot
Plot powder data
gsas2map
Exports a Fourier map in formats used by other programs (for example Fox and DRAWxtl).
liveplot
Invokes the LIVEPLOT program to create a plot of powder data with zooming, automatic update and other nice features.
vrstplot
Create a VRML 3-D file for viewing with 3rd party software
widplt
Displays the FWHM as a function of Q, 2Theta,... for UVWXY values input or read from an EXP file
absplt
The absplt program displays the absorption/reflectivity correction curve for values used in a histogram.
mustrplot
Plot microstrain results
seqplot
Plot results from seqgsas
EXPGUI Screen snapshot

C.6 Results Menu

This menu contains links to several GSAS and one non-GSAS (lstview) programs used for analysis of results.
bijcalc
Thermal parameter analysis
disagl
Distance/angle calculations
disaglviewer
Display results from distance/angle calculations in a graphical browser.
reflist
List reflection data
geometry
Molecular geometry calculations
hstdmp
List powder histogram data
istats
HKL Intensity statistics
rcalc
Compute reflection resuduals
composition
Computes the chemical composition of a unit cell accounting for site multiplicies and occupancies
lstview
Create a box with scrollbars containing the current .LST file
ramafit
Fits torsion angle distributions, particularly in peptide chains, for use in restraints.
seqplot
Plot results from seqgsas
EXPGUI Screen snapshot

C.7 Calculations Menu

This menu contains programs for useful crystallographic computations.
cllchg
Transform unit cell
composition
Computes the chemical composition of a unit cell accounting for site multiplicies and occupancies
rducll
Unit cell reduction
spcgroup
Space group symbol interpreter
seqgsas
Invokes the sequential GSAS refinement program to run GENLES on a set of very similar data files.
seqplot
Plot results from seqgsas
unimol
Unique molecule assembler
EXPGUI Screen snapshot

C.8 Macro Menu New!

The macro capability allows actions performed in EXPGUI to be captured into a file as a series of Tcl command. It is then possible to repeat the actions in a macro repeatedly by replaying the macro. Note that macro files can be edited and Tcl/Tk commands can be added to the macros to expand capabilities. As an example, this code
runAddHist Data.raw 11BM-12D.INS 1 1 T 59.9995
runAddHist Data.raw 11BM-12D.INS 2 2 T 57.9995
runAddHist Data.raw 11BM-12D.INS 3 3 T 55.9995
runAddHist Data.raw 11BM-12D.INS 4 4 T 53.9995
can be modified to prompt for a file name and then use it in a macro:
set DataFile [tk_getOpenFile -defaultextension .raw]
runAddHist $DataFile 11BM-12D.INS 1 1 T 59.9995
runAddHist $DataFile 11BM-12D.INS 2 2 T 57.9995
runAddHist $DataFile 11BM-12D.INS 3 3 T 55.9995
runAddHist $DataFile 11BM-12D.INS 4 4 T 53.9995
Record EXPGUI macro
When this option is turned on, subsequent actions are recorded into the selected macro file.
Add comment to macro
If this option is selected, a window is opened where a string can be typed. This information is then entered at the current point within the macro file as a comment.
Replay macro line-at-a-time
When this option is used, a macro file is selected by the user; the contents of the macro file is displayed, and button can be pressed to execute each command in the macro file. By clicking on a line in a macro file, that line will be the next to be run, so that sections of the file can be skipped over or repeated. The macro can also be edited within the file viewer window.
Replay macro all at once
When this option is used, a macro file is selected by the user, and then all commands in the macro file are executed. A status window is opened that shows the number of refinement cycles, Chi2 and the last sum of shifts and also allows macros to be aborted. Note that any GSAS run in progress will run to completion before the Abort is invoked. Note that Autoload EXP is temporarily set to on and Prompt after GSAS run is temporarily set to off, when this command is invoked, so that the macro runs without need for prompts.
Show GSAS output in window
When this option is selected, GSAS programs are run in a separate window that is created for each program run -- even during macro execution. When this option is deselected, output from GSAS programs is placed in a separate file (XXXXXXXX_mac.LST where XXXXXXXX is the experiment name) and LSTVIEW is opened to view the output from that .LST file.

C.9 Import/Export Menu

This menu contains utilities for importing information into GSAS and exporting it to other programs.
Coord Export
This provides a series of routines that are used to write coordinates and possibly other information to files:

gsas2cif
Prepares IUCr crystallographic information (CIF) file that documents the current refinement. The CIF contains the coordinates for all phases as well as the observed and computed diffraction patterns. The templates used by GSAS2CIF can be customized to provide a detailed description of the experimental measurements and results for use in documenting analysis for publication or deposition.
coords-only CIF
For export of intermediate results to another program, CIF can be a useful exchange format. This routine provides a CIF with the current coordinates from one phase and not much else.
export to DRAWxtl
DRAWxtl is a very useful free program for display of structures and maps. This writes a .STR input file used in the DRAWxtl program and optionally launches DRAWxtl, if installed. While the control options offered by EXPGUI are relatively modest (display of polyhedra, selection for bonds to be drawn, display of Fourier contours), once the DRAWxtl program is launched, the full range of DRAWxtl options can be accessed from that program's GUI. When a Fourier map contour is included, the Fourier parameters are set, the map is computed (program fourier) and is converted to the format needed by DRAWxtl (program gsas2map) automatically.
export to SHELX
This writes coordinates for a selected phase in the .INS format used by SHELX and several other programs.
export to PLATON
This writes coordinates for a selected phase in the .SPF format used by PLATON
export test format
This demonstrates how a coordinate export routine can be added to EXPGUI. See the documentation on this for further information.
export to FOX
This prepares a XML file with coordinates for use in the FOX program
MSI .xtl
Prepare a .XTL format file of atomic positions. This file is used in older Accelrys software such as Cerius and Insight-II. It may no longer be of value.
CIF Export
This provides a series of routines that are used to prepare CIF files:

gsas2cif
Prepares IUCr crystallographic information (CIF) file that documents the current refinement. The CIF contains the coordinates for all phases as well as the observed and computed diffraction patterns. The templates used by GSAS2CIF can be customized to provide a detailed description of the experimental measurements and results for use in documenting analysis for publication or deposition.
FillTemplate
Used to edit the CIF template files used in GSAS2CIF
CIFselect
Used to select interatomic distances and angles to be included in the CIF created by GSAS2CIF.
hklsort
Prepare HKL tables
pubtable
Prepare atom parameter tables
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
cad4rd
Prepare CAD4 single crystal data
dbwscnv
Convert a powder diffraction data file from DBWS format
x17bcnv
Convert an energy dispersive diffractogram data file from NSLS X17b
p3r3data
Prepare Siemens/Brucker P3R3 single crystal data
sxtldata
Prepare generic single crystal data
gsas2pdb
Import (using GSAS2PDB & EXPEDT) and export coordinates (for macromolecular phases) to/from Protein Data Base files
ref2asc
Exports a GSAS reflection file to ASCII for use in non-GSAS programs
ref2bin
Imports an ASCII reflection file to the GSAS binary format
gsas2map
Exports a Fourier map in formats used by other programs (for example Fox and DRAWxtl).
EXPGUI Screen snapshot

EXPGUI top Next page
(Utilities)
Previous page


$Revision: 1225 $ $Date: 2012-11-08 19:42:25 +0000 (Thu, 08 Nov 2012) $