EXPGUI top Next page
(Utilities)
Previous page


EXPGUI, Menu Contents

C. Menu Contents

Note that the figures on this page are likely to be out of date with respect to the text. The text is updated more frequently. Also, note that not all menu options are available in Windows.

C.1 File Menu

The options on the File menu as is the custom contains the commands for reading and writing experiment files, as well as starting and ending the program.
Open
Select an existing GSAS experiment to be used. If a name is entered that does not exists, it is possible to create a new experiment file from scratch.
expnam
Equivalent to Open, included since this is the command used in other GSAS shells to select GSAS experiments.
Save
Saves modifications to the current experiment file to disk (shortcut Alt-S).
Save As
Saves modifications to the current experiment file to disk under a new file name
Reread .EXP file
Reread the last saved version of the experiment file from disk.
EraseHistory
Deletes old history records to speed reading of the .EXP file.
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
exit
Exit EXPGUI (shortcut Alt-X or ^C)
EXPGUI Screen snapshot

C.2 Options Menu

This menu contains options that determine how EXPGUI runs.
archive EXP
Toggles archiving of .EXP files. When on, files are saved before they are overwritten by EXPGUI as a file named EXPNAM.Oxx where xx is a pair of hexidecimal digits (01, 02,..., 09, 0A,... OF, 10,... FF). Each time that EXPGUI archives a file, note is placed in the .LST file so that the saved file name can be associated with the refinement stage. Turning this option off, prevents EXPGUI from creating these EXPNAM.Oxx archive files, but the will still be created by EXPEDT, GENLES,...

Use DISAGL Window
When this option is set, results from DISAGL are shown in a separate window. When it is not set, the results are written in the .LST file. Note that on Windows, LSTVIEW can interfere with putting output into the DISAGL window. The solution is to close LSTVIEW before running DISAGL.
Autoload EXP
Normally EXPGUI prompts before rereading the EXP file when GENLES, POWPREF,... or other GSAS programs run If this option is set, the new file is automatically read without a prompt. The advantage of leaving this option off, is that you can opt to not load the revised .EXP file, which means that you reject the last set of changes. This is useful if GENLES blows up or you have done something wrong. The advantage of turning "autoload EXP" on is that there is one less thing to do when running GSAS programs. Note that it is still possible to reverse changes, if archive files, but this may require more effort.
Iconify during GSAS
If this option is turned on, the main EXPGUI window is shrunk to an icon (minimized) while GSAS programs are running and EXPGUI is suspended. The author prefers this mode, since there is no reason to have the screen cluttered with EXPGUI when it can't be used, but this is an option so that the mode can be turned off by those people who find this behavior annoying.
Sort atoms by
Determines the order that atoms are displayed on the "Phase" pane Atoms may be displayed sorted by number, atom type, site multiplity, occupancy, or by x, y or z coordinate

New! Clicking on the heading above the atoms list cycles with the left mouse button cycles through the atom sort modes. Clicking with the right mouse button resets the atom sort mode to "number".

Sort histograms by
Determines the order that histograms are displayed on the Histogram, Scaling and Profile panes Histograms may be sorted by histogram number, histogram type, original bank number, or diffraction angle/wavelength
Multiple hist. selection
When this mode is off, it is possible to modify parameters and refinement flags for only a single histogram. For other settings, it is possible to modify parameters and flags for groups of histograms (see help for Mouse actions). It does not make sense, however, to globally modify instrument-related parameters and flags for different histogram types. So global actions can be limited to a single class of histogram types (e.g. TOF, CW Neutron,...), which allows these parameters to be set for groups of similar histograms. Thus, if this mode is set to "All" the Histogram and Profile panes are disabled.
Override backspace
This option is available in UNIX only, as there are different ways that backspace can be implemented. When option is set as "On," the backspace key is overridden to send a "delete" character. If backspace does not work in a program such as EXPEDT, change try the other setting for this option.
Set Screen Font New!
This menu changes the fonts used in most sections of EXPGUI. Note that this setting can be saved with the SaveOptions menu option (below) so that EXPGUI automatically starts with the chosen font.
Show EXPTOOL output
Normally EXPGUI does not show the output from EXPTOOL, when actions like adding atoms, phases or histograms is performed. If an error is detected, the output is shown. If there are problems with adding phases, atoms, histograms... and a window showing an error does not appear, this option should be set to "on" so the output from EXPTOOL is always shown.
SaveOptions
Save the current values for "Override backspace", "Sort atoms by", "Sort histograms by", "archive EXP", "Autoload EXP", "Set Screen Font", and "Iconify during GSAS" in file ~/.gsas_config (c:\.gsas_config on Windows).
liveplot_options
Used to set options for LIVEPLOT, for example, the histogram to be plotted
EXPGUI Screen snapshot

C.3 Powder Menu

This menu contains links to GSAS programs used for powder diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
powpref
Powder data preparation (shortcut Alt-P)
genles
Run GSAS experiment editor (shortcut Alt-G)
powplot
Display powder patterns
rawplot
Plot powder data
fitspec
Fit a TOF vanadium scattering spectrum
tofnorm
Normalize a TOF spectrum
bkgedit New!
Invokes the BKGEDIT program to fit a background function to a set of fixed background points.
excledt New!
Invokes the EXCLEDT program to set the upper and lower limits for a histogram, as well as edit excluded regions.
EXPGUI Screen snapshot

C.4 Single Crystal Menu

This menu contains links to GSAS programs used for single-rystal diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
genles
Run GSAS experiment editor (shortcut Alt-G)
scabs
Single crystal absorption
scmerge
Sort and merge single crystal data
sxtldata
Prepare generic single crystal data
EXPGUI Screen snapshot

C.5 Graphics Menu

This menu contains links to several GSAS and two non-GSAS (LIVEPLOT, and widplt) programs used for graphical display of data and results.
forplot
Display Fourier maps (set Fourier options in EXPEDT and then compute with FOURIER
polfplot
Display polefigures
powplot
Display powder patterns
ortep
Draw crystal structure
rawplot
Plot powder data
fourier
Generate Fourier map
forsrh
Search Fourier map for peaks
liveplot
Invokes the LIVEPLOT program to create a plot of powder data with zooming, automatic update and other nice features.
vrstplot
Create a VRML 3-D file for viewing with 3rd party software
widplt
Displays the FWHM as a function of Q, 2Theta,... for UVWXY values input or read from an EXP file
EXPGUI Screen snapshot

C.6 Results Menu

This menu contains links to several GSAS and one non-GSAS (lstview) programs used for analysis of results.
bijcalc
Thermal parameter analysis
disagl
Distance/angle calculations
reflist
List reflection data
geometry
Molecular geometry calculations
hstdmp
List powder histogram data
istats
HKL Intensity statistics
rcalc
Compute reflection resuduals
composition
Computes the chemical composition of a unit cell accounting for site multiplicies and occupancies
lstview
Create a box with scrollbars containing the current .LST file
ramafit
Fits torsion angle distributions, particularly in peptide chains, for use in restraints.
EXPGUI Screen snapshot

C.7 Calculations Menu

This menu contains programs for useful crystallographic computations.
cllchg
Transform unit cell
fprime
Compute f, f', f'' and mu/rho for an element for a range of x-ray wavelengths
rducll
Unit cell reduction
spcgroup
Space group symbol interpreter
unimol
Unique molecule assembler
EXPGUI Screen snapshot

C.8 Import/Export Menu

This menu contains utilities for importing information into GSAS and exporting.
exp2xtl
Prepare a .XTL format file of atomic positions. This file is used in MSI software such as Cerius and InsightII.
gsas2cif
Prepare IUCr crystallographic information (CIF) file
hklsort
Prepare HKL tables
pubtable
Prepare atom parameter tables
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
cad4rd
Prepare CAD4 single crystal data
dbwscnv
Convert a powder diffraction data file from DBWS format
x17bcnv
Convert an energy dispersive diffractogram data file from NSLS X17b
p3r3data
Prepare Siemens/Brucker P3R3 single crystal data
sxtldata
Prepare generic single crystal data
gsas2pdb
Import (using GSAS2PDB & EXPEDT) and export coordinates (for macromolecular phases) to/from Protein Data Base files
ref2asc
Exports a GSAS reflection file to ASCII for use in non-GSAS programs
ref2bin
Imports an ASCII reflection file to the GSAS binary format
EXPGUI Screen snapshot

EXPGUI top Next page
(Utilities)
Previous page
Brian Toby (Brian.Toby@NIST.GOV)
$Revision: 522 $ $Date: 2009-12-04 23:07:34 +0000 (Fri, 04 Dec 2009) $