Link to NIST Center for Neutron Research home page Link to National Institute of Standards & Technology home page
Link to Tcl/Tk information


EXPGUI top LIVEPLOT page Previous page

EXPGUI, Menu Contents

C. Menu Contents

C.1 File Menu

The options on the File menu as is the custom contains the commands for reading and writing experiment files, as well as starting and ending the program.
expnam
Select an existing GSAS experiment to be used. If a name is entered that does not exists, it is possible to create a new experiment file from scratch.
Save
Saves modifications to the current experiment file to disk (shortcut Alt-S).
Save As
Saves modifications to the current experiment file to disk under a new file name
Reread .EXP file
Reread the last saved version of the experiment file from disk.
EraseHistory
Deletes old history records to speed reading of the .EXP file.
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
exit
Exit EXPGUI (shortcut Alt-X or ^C)
EXPGUI Screen snapshot

C.2 Options Menu

This menu contains options that determine how EXPGUI runs.
archive EXP
Toggles archiving of .EXP files. When on, files are saved prior to each save or run of EXPEDT. Each time a file is saved a note is placed in the .LST file so that the saved file name can be associated with the refinement stage.

UNIX: Old .EXP files are saved in a compressed file named [expnam].EXP.xxx.gz where xxx = 000, 001..., if the the gzip program can be run by EXPGUI, or in an uncompressed file named [expnam].EXP.xxx if gzip is not available.

Archived files can be loaded by using the File/Open (expnam) command: set the "Include Archived Files" checkbox, then select the file to be loaded. When an archived file is read, either the same experiment name can be used. In which case the archived file will replace the current version of the experiment file, or the archived file can be saved under a new name.

Windows: Old .EXP files are saved in a compressed form in a file named [expnam].ZIP, if program PKZIP.EXE is found in the same directory where EXPGUI is installed (typically c:\gsas\expgui). To read the archived files, you will need to use PKZIP or WINZIP to extract and rename them. If PKZIP is not installed, the files are archived by renaming them [expnam]!xxx.EXP. These archived files can be read directly by EXPGUI, but you are suggested to save them under a new name using the File/"Save As" option.

Use DISAGL Window
When this option is set, results from DISAGL are shown in a separate window. When it is not set, the results are written in the .LST file. Note that on Windows, LSTVIEW can interfere with putting output into the DISAGL window. The solution is to close LSTVIEW before running DISAGL.
Autoload EXP
Normally EXPGUI prompts before rereading the EXP file when GENLES, POWPREF,... or other GSAS programs run If this option is set, the new file is automatically read without a prompt. The advantage of leaving this option off, is that you can opt to not load the revised .EXP file, which means that you reject the last set of changes. This is useful if GENLES blows up or you have done something wrong. The advantage of turning "autoload EXP" on is that there is one less thing to do when running GSAS programs. Note that it is still possible to reverse changes, if archive mode is on, but this may require more effort.
Iconify during GSAS
If this option is turned on, the main EXPGUI window is shrunk to an icon (minimized) while GSAS programs are running and EXPGUI is suspended. The author prefers this mode, since there is no reason to have the screen cluttered with EXPGUI when it can't be used, but this is an option so that the mode can be turned off by those people who find this behavior annoying.
Sort atoms by
Determines the order that atoms are displayed on the "Phase" pane Atoms may be displayed sorted by number, atom type, site multiplity, occupancy, or by x, y or z coordinate

New! Clicking on the heading above the atoms list cycles with the left mouse button cycles through the atom sort modes. Clicking with the right mouse button resets the atom sort mode to "number".

Sort histograms by
Determines the order that histograms are displayed on the Histogram, Scaling and Profile panes Histograms may be sorted by histogram number, histogram type, original bank number, or diffraction angle/wavelength
Multiple hist. selection
When this mode is off, it is possible to modify parameters and refinement flags for only a single histogram. For other settings, it is possible to modify parameters and flags for groups of histograms (see help for Mouse actions). It does not make sense, however, to globally modify instrument-related parameters and flags for different histogram types. So global actions can be limited to a single class of histogram types (e.g. TOF, CW Neutron,...), which allows these parameters to be set for groups of similar histograms. Thus, if this mode is set to "All" the Histogram and Profile panes are disabled.
Override backspace
This option is available in UNIX only, as there are different ways that backspace can be implemented. When option is set as "On," the backspace key is overridden to send a "delete" character. If backspace does not work in a program such as EXPEDT, change try the other setting for this option.
Show EXPTOOL output
Normally EXPGUI does not show the output from EXPTOOL, when actions like adding atoms, phases or histograms is performed. If there are problems, this option should be set to "on" so the error can be determined.
SaveOptions
Save the current values for "Override backspace", "Sort atoms by", "Sort histograms by", "archive EXP", "Autoload EXP", and "Iconify during GSAS" in file ~/.gsas_config (c:\.gsas_config on Windows).
liveplot_options
Used to set options for LIVEPLOT, for example, the histogram to be plotted
EXPGUI Screen snapshot

C.3 Powder Menu

This menu contains links to GSAS programs used for powder diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
powpref
Powder data preparation (shortcut Alt-P)
genles
Run GSAS experiment editor (shortcut Alt-G)
powplot
Display powder patterns
rawplot
Plot powder data
fitspec
Fit a TOF vanadium scattering spectrum
tofnorm
Normalize a TOF spectrum
bkgedit
Invokes the BKGEDIT program to fit a background function to a set of fixed background points.
EXPGUI Screen snapshot

C.4 Single Crystal Menu

This menu contains links to GSAS programs used for single-rystal diffraction analysis.
expedt
Run GSAS experiment editor (shortcut Alt-E)
genles
Run GSAS experiment editor (shortcut Alt-G)
scabs
Single crystal absorption
scmerge
Sort and merge single crystal data
sxtldata
Prepare generic single crystal data
EXPGUI Screen snapshot

C.5 Graphics Menu

This menu contains links to several GSAS and two non-GSAS (LIVEPLOT, and widplt) programs used for graphical display of data and results.
forplot
Display Fourier maps (set Fourier options in EXPEDT and then compute with FOURIER
polfplot
Display polefigures
powplot
Display powder patterns
ortep
Draw crystal structure
rawplot
Plot powder data
fourier
Generate Fourier map
forsrh
Search Fourier map for peaks
liveplot
Invokes the LIVEPLOT program to create a plot of powder data with zooming, automatic update and other nice features.
vrstplot
Create a VRML 3-D file for viewing with 3rd party software
widplt
Displays the FWHM as a function of Q, 2Theta,... for UVWXY values input or read from an EXP file
EXPGUI Screen snapshot

C.6 Results Menu

This menu contains links to several GSAS and one non-GSAS (lstview) programs used for analysis of results.
bijcalc
Thermal parameter analysis
disagl
Distance/angle calculations
reflist
List reflection data
geometry
Molecular geometry calculations
hstdmp
List powder histogram data
istats
HKL Intensity statistics
rcalc
Compute reflection resuduals
composition
Computes the chemical composition of a unit cell accounting for site multiplicies and occupancies
lstview
Create a box with scrollbars containing the current .LST file
EXPGUI Screen snapshot

C.7 Calculations Menu

This menu contains programs for useful crystallographic computations.
cllchg
Transform unit cell
fprime
Compute f, f', f'' and mu/rho for an element for a range of x-ray wavelengths
rducll
Unit cell reduction
spcgroup
Space group symbol interpreter
unimol
Unique molecule assembler
EXPGUI Screen snapshot

C.8 Import/Export Menu

This menu contains utilities for importing information into GSAS and exporting.
exp2xtl
Prepare a .XTL format file of atomic positions. This file is used in MSI software such as Cerius and InsightII.
gsas2cif
Prepare IUCr crystallographic information (CIF) file
hklsort
Prepare HKL tables
pubtable
Prepare atom parameter tables
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
cad4rd
Prepare CAD4 single crystal data
dbwscnv
Convert a powder diffraction data file from DBWS format
x17bcnv
Convert an energy dispersive diffractogram data file from NSLS X17b
p3r3data
Prepare Siemens/Brucker P3R3 single crystal data
sxtldata
Prepare generic single crystal data
EXPGUI Screen snapshot

EXPGUI top LIVEPLOT page Previous page
Brian Toby (Brian.Toby@NIST.GOV)
$Revision: 405 $ $Date: 2009-12-04 23:05:37 +0000 (Fri, 04 Dec 2009) $