Using EXPGUI

Introduction

EXPGUI allows two types of actions: it allows the different GSAS programs such as EXPEDT, GENLES, FOURIER,... to be run, and it can be used to directly modify the GSAS experiment file without using EXPEDT.

Note that pictures on this page are somewhat out-of-date with respect to the current software version so they may differ from what is described in the text.

Programs are invoked either through use of the menu bar


The menu bar.
or by "pressing" a button on the button bar. The button bar simply provides an easy way to access commonly used actions on the menu bar. Users can configure the menu bar to include their own preferred actions and, with some knowledge of the program and Tcl/Tk, add their own commands to the menu bar or button bar.

The button bar.

Different sections of the .EXP file can be edited by selecting different panels or pages from the tabbed list. These tabs will have slightly different appearance depending on the packages available with your local version of Tcl/Tk.


The panel tabs using the Tix package.

The panel tabs without the Tix package.
If the Tix package is loaded on your machine, it will be used, but if it is not, EXPGUI will run fine without it.

This documentation will describe the different actions that can be accomplished with the different panels and the contents of the menus. Other documents contain: Installation notes for Windows, Installation notes for UNIX and Customization notes.


1. LS Controls panel

The LS Controls panel shows information about the current experiment, typically found in the EXPEDT "Least Squares Controls" options.

Note that the order that histograms appear in this panel is determined by the "Sort histograms by" option in the Options Menu.

2. Phase panel

The phase panel is used to edit information about the phase or phases found in the experiment file. The cell and atomic damping and refinement flags can be changed here. Note that if a single atom is selected using the mouse, the information for that atom can be edited. If a group of atoms is selected (see Mouse Actions) the damping and refinement flags for all the selected atom can be changed at one time.

If the EXPTOOL program (see the installation instructions) is installed, buttons for adding phases and atoms will appear on this panel, as seen below. If the program is not properly installed, no errors occur, but the buttons do not appear.

Note that the order that atoms appear in this panel is determined by the "Sort Atoms by" option in the Options Menu.

3. Histogram panel

The histogram panel is used to edit background and diffractometer constants for a histogram, as well as set damping and refinement flags for these parameters.

If "Multiple Histogram Selection" mode is set to "All", this panel is disabled. For other settings of this mode, groups of histograms can be selected and modified collectively.

If the EXPTOOL program (see the installation instructions) is installed, a button for adding histograms will appear on the bottom right on this panel, as seen below. If the program is not properly installed, no errors occur, but the button does not appear.

Note that the order that histograms appear in this panel is determined by the "Sort histograms by" option in the Options Menu.

4. Scaling panel

The Scaling panel is used to edit the scale factor for a histogram as well as the phase fractions for each phase present in that histogram. Damping and refinement flags can also be set here.

If "Multiple Histogram Selection" mode is set to any value other than "Off," groups of histograms can be selected and modified collectively.

Note that the order that histograms appear in this panel is determined by the "Sort histograms by" option in the Options Menu.

5. Profile panel

The Profile panel is used to edit the profile values for each phase present in a histogram as well as set the refinement flags and a damping value for each phase.

If "Multiple Histogram Selection" mode is set to "All", this panel is disabled. For other settings of this mode, profile values and settings can be collectively modified for groups of histograms.

Note that the order that histograms appear in this panel is determined by the "Sort histograms by" option in the Options Menu.

6. Multiple Histogram Selection

This mode allows parameters to be changed for groups of histograms. When the "Multiple Histogram Selection" mode is off, it is possible to modify parameters and refinement flags for only a single histogram, but the other settings allow groups of histograms to be selected and modified. (see Mouse Actions). It does not make sense, however, to globally modify instrument-related parameters and flags for different histogram types. So global actions can be limited to a single class of histogram types (e.g. TOF, CW Neutron,...), which allows these parameters to be set for groups of similar histograms. Thus, if this mode is set to "All" the Histogram and Profile panels are disabled.

The setting for "Multiple Histogram Selection" mode is selected using the "Multiple Hist. Selection" item on the Options menu.

7. Mouse Actions

A range of atoms or (in multiple selection mode) histograms may be selected by dragging (holding down) the left mouse button. It is also possible to select a range by using the Shift key with the left mouse button. To select or deselect individual entries, use the Control key with the left mouse button. Pressing the right mouse button selects all entries in a list.

8. Menus

A description of the EXPGUI menus follows along with a very brief description of the function of each menu option. Note that an option may appear under more than one menu.

8.1 File Menu

The options on the File menu as is the custom contains the commands for reading and writing experiment files, as well as starting and ending the program.
expnam
Select an existing GSAS experiment to be used or create a new experiment file from scratch.
Save
Saves modifications to the current experiment file to disk
Save As
Saves modifications to the current experiment file to disk under a new file name
Reread .EXP file
Reread the last saved version of the experiment file from disk.
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
exit
Exit EXPGUI

8.2 Options Menu

This menu contains options that determine how EXPGUI runs.
archive EXP
Toggles archiving of .EXP files. When on, files are saved prior to each save or run of expedt in a file named [expnam].EXP.xxx.gz where xxx = 000, 001 (UNIX) or in a file named [expnam].ZIP or [expnam].xxx (Windows)
Sort atoms by
Determines the order that atoms are displayed on the "Phase" page Atoms may be displayed sorted by atom number, atom type, or by x, y or z
Sort histograms by
Determines the order that histograms are displayed on the Histogram, Scaling and Profile pages Histograms may be sorted by histogram number, histogram type, original bank number, or diffraction angle/wavelength
Multiple hist. selection
When this mode is off, it is possible to modify parameters and refinement flags for only a single histogram. For other settings, it is possible to modify parameters and flags for groups of histograms (see help for Mouse actions). It does not make sense, however, to globally modify instrument-related parameters and flags for different histogram types. So global actions can be limited to a single class of histogram types (e.g. TOF, CW Neutron,...), which allows these parameters to be set for groups of similar histograms. Thus, if this mode is set to "All" the Histogram and Profile pages are disabled.
Override backspace
This option is available in UNIX only, as there are different ways that backspace can be implemented. When option is set as "On," the backspace key is overridden to send a "delete" character. If backspace does not work in a program such as EXPEDT, change try the other setting for this option.
Autoupdate EXP
Normally EXPGUI prompts before rereading the EXP file when GENLES, POWPREF,... are run (this is so that one can change the experiment file and rerun with the current input). If this option is set, the new file is automatically read without a prompt.
SaveOptions
Save the current values for "Override backspace", "Sort atoms by", "Sort histograms by" and "archive EXP" in file ~/.gsas_config (c:\.gsas_config on Windows).
liveplot_options
Used to set options for liveplot, for example, the histogram to be plotted

8.3 Powder Menu

This menu contains links to GSAS programs used for powder diffraction analysis.
expedt
Run GSAS experiment editor
powpref
Powder data preparation
genles
Run GSAS experiment editor
powplot
Display powder patterns
rawplot
Plot powder data
fitspec
Fit a TOF vanadium scattering spectrum
tofnorm
Normalize a TOF spectrum

8.4 Single Crystal Menu

This menu contains links to GSAS programs used for single-rystal diffraction analysis.
expedt
Run GSAS experiment editor
powpref
Powder data preparation
scabs
Single crystal absorption
scmerge
Sort and merge single crystal data
sxtldata
Prepare generic single crystal data

8.5 Graphics Menu

This menu contains links to several GSAS and two non-GSAS (liveplot and widplt) programs used for graphical display of data and results.
forplot
Display Fourier maps (set Fourier options in EXPEDT and then compute with FOURIER
polfplot
Display polefigures
powplot
Display powder patterns
ortep
Draw crystal structure
rawplot
Plot powder data
fourier
Generate Fourier map
forsrh
Search Fourier map for peaks
liveplot
Create a plot of powder data with zooming, automatic update and other nice features.
vrstplot
Create a VRML 3-D file for viewing with 3rd party software
widplt
Displays the FWHM as a function of Q, 2Theta,... for UVWXY values input or read from an EXP file

8.6 Results Menu

This menu contains links to several GSAS and one non-GSAS (lstview) programs used for analysis of results.
bijcalc
Thermal parameter analysis
disagl
Distance/angle calculations
reflist
List reflection data
geometry
Molecular geometry calculations
hstdmp
List powder histogram data
istats
HKL Intensity statistics
rcalc
Compute reflection resuduals
composition
Computes the chemical composition of a unit cell accounting for site multiplicies and occupancies
lstview
Create a box with scrollbars containing the current .LST file

8.7 Calculations Menu

This menu contains programs for useful crystallographic computations.
cllchg
Transform unit cell
fprime
Compute f, f', f'' and mu/rho for an element for a range of x-ray wavelengths
rducll
Unit cell reduction
spcgroup
Space group symbol interpreter
unimol
Unique molecule assembler

8.8 Import/Export Menu

This menu contains utilities for importing information into GSAS and exporting.
exp2xtl
Prepare a .XTL format file of atomic positions. This file is used in MSI software such as Cerius and InsightII.
gsas2cif
Prepare IUCr crystallographic information (CIF) file
hklsort
Prepare HKL tables
pubtable
Prepare atom parameter tables
convert
Convert a standard ASCII file to the direct access format used by GSAS (and for UNIX, the reverse)
cad4rd
Prepare CAD4 single crystal data
dbwscnv
Convert a powder diffraction data file from DBWS format
x17bcnv
Convert an energy dispersive diffractogram data file from NSLS X17b
p3r3data
Prepare Siemens/Brucker P3R3 single crystal data
sxtldata
Prepare generic single crystal data

9. EXPGUI Utility Programs

LSTVIEW

lstview is used to browse through the GSAS output listing. It is invoked by the "lstview" command in the GUI.

LIVEPLOT

liveplot shows the observed, calculated and difference plots for powder refinements. The plot is updated as the refinement progresses. The mouse can be used to zoom in on sections of the plot.

LIVEPLOT can now be enhanced to superimpose peak locations for input unit cells or peaks from JCPDS/ICDD entries. See the LIVEPLOT customization information or read file expgui_cfg.html in the gsas/tcl/doc directory.

LIVEPLOT gets the current diffraction information by running the TCLDUMP program, if installed, or HSTDUMP otherwise. The TCLDUMP program has been optimized for use with LIVEPLOT and offers a number of extra options that are not available when HSTDUMP is used: plots can be displayed in the native units (2Theta/TOF/KeV), or in d-space or Q; fixed plus fitted background curves are shown in green; if reflection tickmarks are displayed, reflection tickmarks can be displayed by holding the shift key while pressing the left mouse button. See the installation instructions for installing TCLDUMP.

WIDPLT

widplt can be used to plot the actual peak widths generated by the profile parameters used in GSAS. It is possible to define reference curves that are loaded automatically.


Acknowledgements

Praise to Larson and Von Dreele for GSAS, Ousterhout for Tcl/Tk, Przemek Klosowski for convincing me to learn Tcl/Tk and Jonathan Wasserman for starting this project.
GSAS is written by Allen C. Larson and Robert B. Von Dreele, MS-H805, Los Alamos National Laboratory, Los Alamos, NM 87545. Problems, questions or kudos concerning GSAS should be sent to Robert B. Von Dreele at vondreele@lanl.gov

GSAS is Copyright, 1984-1997, The Regents of the University of California. The GSAS software was produced under a U.S. Government contract (W-7405-ENG-36) by the Los Alamos National Laboratory, which is operated by the University of California for the U.S. Department of Energy. The U.S. Government is licensed to use, reproduce, and distribute this software. Permission is granted to the public to copy and use this software without charge, provided that this notice and any statement of authorship are reproduced on all copies. Neither the Government nor the University makes any warranty, express or implied, or assumes any liability or responsibility for the use of this software.

EXPGUI is written by Brian H. Toby of the NIST Center for Neutron Research, Brian.Toby@NIST.GOV with help from Jonathan Wasserman.

EXPGUI is not subject to copyright. Have fun with it.

Neither the U.S. Government nor any author makes any warranty, expressed or implied, or assumes any liability or responsibility for the use of this information or the software described here. Brand names cited here are used for identification purposes and do not consitute an endorsement by NIST.

Brian Toby (Brian.Toby@NIST.GOV)
$Revision: 108 $ $Date: 2009-12-04 23:00:32 +0000 (Fri, 04 Dec 2009) $